Graswald


(Kareem Ahmad) #402

yes that would be awesome. You can pm it to me


(Kareem Ahmad) #403

I found one bug. They fixed an issue in the API that I had accommodated. Now just need to undo that accommodation.

EDIT : there’s a lot of changes… so scratch that.

For now I may need to drop backwards compatibility. This is tentative… but the api is changing.


(Julius Harling) #404

Uploaded it :wink:


(Kareem Ahmad) #405

@kless

If you care to know where the issue comes from: I wanted some way for graswald to be able to deal with systems on objects that have been duplicated. So that they can be treated independently if one wants. There was no clean way to do it, so I had objects track the systems on them by some—not great method. Your post still thinks it has graswald systems on it. So clicking it selects the system it thinks it carries. Selecting a system with autoselect emitter enabled selects the object emitting it, which wasn’t that pole. So thus the issue you had. If the system was already selected, it doesn’t do anything and that’s why you could probably select on the next attempt.

I’m not sure I can fix this without an update that will break backwards compatibility. So for now just turn off “autoselect emitter” if the issue comes up.

I’ll fix it in 2.8, and clean up some other messy implementations, since the compatibility will break anyway. I may, once the 2.8 version is done, make a retroactive final version of 2.79 that fixes these issues. This would be forward compatible, but not backwards compatible, for those that want to continue working with 2.79 but still have the option of migrating later. But for now, time to refactor.


(kless) #406

Ah works great now, thank you for the help and fast response.


(Nicholas Pritchard) #407

I’m using the latest version of blender 2.8 (1-13-19 release) and Graswald_28_01b and I’m getting this error when I attempt to activate the addon.


(dazza66) #408

Hi, I Can’t Activate the 28_01b, I couldn’t Activate 28_01a either, I keep getting error messages every time I try and activate, I am using the latest blender 2.80 of the 13th of January.
I don’t know if it’s me or Graswald is being a little Buggy still, though I have noticed other people have got it working so Umm, maybe it’s me, I would really appreciate your thoughts on the matter


(Kareem Ahmad) #409

Its buggy in the Jan 13 version. API continues to change. It’ll be a bit of time before I have a fix. Gonna do some refactoring.


(dazza66) #410

thank you for letting me know, I thought I was getting it wrong


(jachtarfranko) #411

If it is more easy for you, to break backwards compatibility is OK for me.


(sun yufang) #412

Screenshot_20190116_082819
I use Graswald_28_01b and I’m getting this error when I attempt to activate the addon.


(Kareem Ahmad) #413

Yes, the 2.8 is broken right now because of a change in Blender’s behavior. A patch should come soon. I’ll announce when ready.


(Kareem Ahmad) #414

I believe I have fixed the 2.8 graswald. I’ll have Julius upload it as soon as he gets the chance.