Graswald


(Julius Harling) #422

Normally it will be posted in the Graswald RELEASE thread:


(Kareem Ahmad) #423

28_01c is available now


(jachtarfranko) #424

Works well, thanks


(ajharmon89) #425

Thanks for the updated version! It now installs correctly. :slight_smile:

Now my issue is that when I click on the + button I get an error message, and Blender can’t seem to find any of the plant models. Any idea why this would be?


(ajharmon89) #426

I ended up restarting and trying again, and this time everything seems to be working well! :slight_smile:


(skarkkai) #427

I’ve also noticed that the objects with Grasswald systems on them keep accumulating particle systems that don’t show in Graswald UI, as well as empty material slots. All of this might be somehow related to the fact that I’ve been duplicating the objects with Graswald systems.


(skarkkai) #428

Renaming the object with a Graswald system on it seems to be a good way to make Graswald lose track of the particle system, which will then result in weirdness. And that of course happens when duplicating objects. It would be nice if Graswald were smarter in those situations. Does Graswald rely the particle system having a name generated from the grass species and variant?


(Kareem Ahmad) #429

Graswald should be using pointers to keep track of emitter references, and while particle systems are given a default name, the name isn’t how they are accessed later on…

I’ll definitely look into this issue.


(skarkkai) #430

Saving seems to be what triggers possibly all of these problems. Today I’ve not had any problems until I save, at which point often all or at least amost of the systems start immediately showing black (or transparent for high detail systems). Needless to say this is making Graswald nearly unusable for me.


(skarkkai) #431

Given that using the latest version 1.15 is a pretty frustrating experience, can I download the previous version somewhere? In general it’s nice to be able to install also earlier versions of software.


(Kareem Ahmad) #432

I’m not sure, Julius typically manages all the uploads.

But you’ve given a lot of details, so I should hopefully be able to resolve all the issues in short time.


(Kareem Ahmad) #433

The way graswald deals with duplicates, is that it offers you a button to
image

If you don’t… issues may arise. I need a better way to deal with duplication… but that will also break backwards compatibility.


(Kareem Ahmad) #434

I cannot seem to replicate the error in 1.15 nor the would be 1.16

Do these errors still show themselves if you don’t mess around with duplicating objects?


Actually let’s try this. Go to your addon directory (probably {username}/Appdata/Roaming/Blender Foundation/Blender/2.79/scripts/addons )
And edit this file: Graswald/helpers/gen_handles.py

Just add the # as shown.

Then tell me if this fixes the issue. If it does, that really narrows down our search.

And let’s continue this in PM


(skarkkai) #435

Just letting people know we got this bug figured out and it should be fixed in the next version 1.16.


(Alan) #436

Very frustrating. Bought this months ago, haven’t been able to use it since.
Bought again, in December.

Latest version, Graswald_28_01c, does not install, can’t read code text - is off screen left.
Have removed. Useless.

Mac OSX 10.14.3, 3.2 GHz Intel Core i5, NVIDIA GeForce GTX 680MX 2048 MB

Alan A.


(Kareem Ahmad) #437

You can open the terminal window to see the text. Go to Window>Toggle System Console.

When you see the error, you can report it here and we can get it fixed as soon as possible.

As for 28_01c make sure you are using the latest version of blender 2.8

1.15 should install fine on 2.79b


(Alan) #438

Thanks for reply. I am not code savvy. Best I can do is enclosed. This happens after i click "Install add on from file…
I have a folder Graswald I downloaded. I compressed to Graswald.zip. Got this:

Regards,
Alan


(duketogo) #439


I couldn’t install 2.8 01c on latest Blender 2.8


(Kareem Ahmad) #440

@AWA1 When you install it, you often have to restart blender before it will work/you can activate it. Lemme know if this works.

I just tested it on the newest build, and it’s working for me.


(duketogo) #441

2.8 01c is working on 2.8. And fast with eevee.
Thank you