Graswald

Hello Kareem,

I ul the latest Blender build and installed Graswald! Yay. Thanks.

Now, where do I find it in 2.8? I’ve looked all over.

Perhaps give me some steps to follow? The Graswald video is worthless, need a 2.8 version.

Thanks,

Alan

Graswald is in the 3D viewport panel that you open with ‘N’ (as opposed to ‘T’ which is where it used to be)

As for the video—we’ll update it when the 2.8 becomes official. For now 2.79 is still the official Graswald. (I have some updates that’ll break backwards compatibility before that happens, lots of internal changes)

Thanks for addon!
how can I display the lost picture?


some species shade emitting like this, others shade fine.

I guess screen space reflections make it shiny.

Hi, I’ve ran into a bug that causes some of the grass in a scene to go black after saving here is a before and after image.

I believe this is the same as what skarkkai pointed out, I’ll push that update to Julius have him upload the fix as soon as we can

1 Like

wow, that scene looks pretty cool, though! Be sure to keep me posted :wink:

1 Like

I am able to save the file now without the grass being black after I changed the quality of the material. One last thing the colors are now slightly different in the dead patches and the file size has been cut in half from 735 to 369 MB.

1 Like

If you can send before/after for the dead patches, I can see if the issue is in the textures or elsewhere

Here you go its a small difference

1 Like

I also had some issues with the dead patches looking different between saves but I never really noticed until near the end of my project. For sure it’s a bug.

Actually just fixed it, in the material tab there were these empty materials when I removed them and saved the file no more black grass and the dead patches of grass are the correct color. The file size is still different from the original, went from 735 to 654 this time. I’ve also noticed that when deleting a system from the graswald menu it will leave behind an empty particle system.

2 Likes

I encountered another problem, not with the add-on, but in general. I tried using often suggested patches instead of single models, but I found that the memory doubled and also a slightly longer render time… Any idea why?

2 Likes

Nice to see some tests to try larger areas (even if the tests are not going as hoped). For use in real archviz scenes being able to scatter around grass on huge areas is a must. If grasswald could be a forestpack for blender I would switch to blender right away.

2 Likes

I guess if you instance a heavier model the geometry doubling is no surprise…
That’s what 's instancing’s about isn’t it ?
And I guess rendertimes are also a bit geometry dependent.
Not a coder though so maybe someone wiser explains…

Jarek D(DJ)

I had a similar issue when I tried creating Graswald patches. I used patches all the time in ForestPack and it would reduce memory usage. I’m guessing it has something to do with Blender’s instancing system. I wonder if when Everything Nodes is done we can use something other than particles to scatter grass.

I’m having the same problem here as a few users above had, in which the materials aren’t loading when I reopen a file. I’m in 2.8, using the latest GrasWald (01c.zip).

What were the solutions to this?

EDIT: I switched the materials to medium and they came back on. I’ll try switching them back to High and see if that works.

EDIT 2: Nope, it didn’t work. I’ll try switching back to Medium, saving, reopening, and then switching back to the High quality materials.

EDIT 3: I upgraded to the latest 2.8 and it seems to work again.

EDIT 4: Nope, it’s still not working. The materials are all over the place. Some work with High, some with Medium, and some with Low.

This is super frustrating.

1 Like

I haven’t had a chance to do any maintenance since January, so I cant claim full compatibility with the latest 2.8.

See full response in Graswald_Release

Hi, I recently purchased Graswald and was playing around with it tonight and came across this. Some of the flowers have the origin in the center, so they’re not emitting like they should. I’m still using 2.79.