Gravity going crazy with an armature

I started to make a Kirby model with simply walking animation but I noticed that after I link my mesh to the armature and press ‘P’ the Kirby flies through the floor with a quite fast speed. This is when both the mesh and armature have ‘actor - dynamic’ physics enabled, if I set it off from the armature, Kirby doesn’t even fall. Would anybody know why it does this?

Here’s the blend file:
http://www.mediafire.com/?jcmyidimbom

Hello
select the character and disable “collision” for all faces…it should work, I hope?!
Bye

It shouldn’t even have collisions enabled, at least I didn’t touch those physics buttons. By the way I’m a total newbie with physics so it could be anything really simple…

it has collision enabled by default, select the mesh go in edit mode, select all the face (press A) then press ctrl+F ----> Face mode clear --¨> collisions.

Worked! Thank you very much for both of you!