Gray screen problem

When im out of camera mode, there is no problem, but when I get in camera mode a grey screen on half of the screen appears and it stays there even when I render, I’m using 2.8.1

It appears that your camera is clipping out the distant parts. There is a set limit (min and max) to what is visible in a camera, but it can be changed.

To fix it, you need to change the Clip End value in the camera settings.
image

If the issue also exists when viewing the scene outside of the cameras, set it in the properties panel (N key) as well:
image

Thank you so much man, fixed

But, what about 2.79

Here:
image

…and here:
image

It’s pretty much the same.