Grease pencil just got realtime lights

game changer anyone know where i can download the branch?

1 Like

I suppose one of these days, a blender 2.83 alpha download on https://builder.blender.org/download/ ?

Or a greasepencil branch on https://blender.community/c/graphicall/Whbbbc/ ?

Or here other branches: https://builder.blender.org/download/branches/
Confused a bit now.

cheers peetie

No. That is not in master, yet. And that was not done in greasepencil-object branch.
Name of the branch is greasepencil-refactor.

2 Likes

hi zeauro could you post the link

cheers buddy

hi zeauro I just downloaded blender 2.83 …cant find the new feature could you do me a favour if of course you have the time and post a screen shot of where the new feature is located

I downloaded both 2.82 experimental grease pencil build and 2.83 as well. Nothing there yet - no “Use lights” option under opacity slider. Am I missing something?

Sorry. I made a mistake.
I did not succeeded to build greasepencil-object branch.
Although I had no problem with greasepencil-refactor branch.
So, I compared histories of git repo to look if there was commit from Clément about lights in greasepencil-object branch.
But when I did that, I was confused by a commit of Clément about regular lamp in master.

So, I downloaded greasepencil-object branch, this morning.
And yes. That does not work in that branch. And they don’t provide build for that.
I suppose that they automatically post a link to 2.83 alpha and experimental builds under all videos about blender development without checking if it is relevant or not.

So, you have to build refactor branch, yourself if you want to test it.
But shadows are not there, yet.
I suppose that branch will be merged into master when that will be the case.

2 Likes

Cheers for the heads up zeauro

1 Like

hi, thought I’d revive this thread since now the refactor branch is available in the 2.83 experimental builds. I downloaded it, got the ‘Use lights’ checkbox but still can’t get it to work. Anyone has an idea on how do it?

Hi Jack, it works fine now so does vertex paint it was not in the experimental build yesterday …you might just need to download the very latest build i downloaded it about a hour ago …by the way you know if you have the correct build if under fx panel the light icon is no longer showing also area light does not emmit a square light spotlight works fab and as expected kudos and lots of props to the greasepencil team for making this happen this build is a game changer

There are 2 “Use Lights” Checkbox.
One that is a per layer option inside Layers panel of Object Data Properties tab.
One that is global for the whole object, inside Grease Pencil panel of Object Properties tab.
That last one is by default, disabled for Stroke object of 2D animation template.

Thanks guys! Got yesterday’s build and was still puzzled. Spot light would work if I started from a general startup file but not when starting with a 2D animation one. Indeed, it was because I didn’t know about the Object tab checkbox. Everything working fine now.

And yes, what an improvement! Especially when it comes to antialiasing and playback speed, it’s awesome! Also, the effects (like glow) are much smoother.

1 Like