Grid not showing in orthographic views in version 2.8

How do I turn on the grid in the orthographic views? It only shows in perspective and only on the floor x,y dimensions. Can it be turned on for z, x and z,y directions also?

Thanks for any help

This seems to be a bug at the moment I think. You ought to get the grid in orthographic views (front/right etc. and then set to Orthographic) as in 2.79 as far as I know, but it does not seem to be working currently. I’m looking to see if there’s an existing bug for this and will get one entered if there isn’t.

Should already be fixed. See both of these at least:
https://developer.blender.org/T61632
https://developer.blender.org/T61650

I discovered that this happens in the View menu. When changing the settings of “Clip Start” and “End.”

When Clip Start is set at 5m and End is set at 100m I get the grid in ortho. If I begin to vary the settings of either I can actually see the grid start to fade.

If I set the Start to 10m and keep the End value at 100m The grid gets brighter.

If I keep the Start value at 10m and change the End value to 200m the grid fades.

With Start at 10. and the End at 400m the grid is barely visible.

I have played with different settings for both and these fluctuations occur. The examples I typed are just one where I kept the start at 10 and changed the end value.

If the Start is at 5m and the End is set to 50m it is fairly bright. But to change the End value to 100m the grid again is gone.

Well at least I can sort of control this problem.

The version I am using is blender-2.80-319b9d6501f2-win64 which I downloaded today, the 17th of February.

Download the latest today and you should find the problem is fixed.

Thanks Pixelfox…new version works perfectly!