Grizzly Bear

I have started working on a grizzly bear. I think I am done with the modeling. I am having trouble with the fur. As you can see in this picture, this was my first attempt at it. I am trying to have two different particle systems. One for the body fur, and another for the face. The face fur is supposed to be shorter and lighter. Any suggestions on conquering this bad-body?

Attachments



Hi Mike, you might try going into particle mode and cut the the hair around the face.

You don’t really need a second particle system, you can affect various hair parameters like length either with vertex groups, or with textures, or both.

you may need to have two particle systems, but not necessarily. if you use one particle system: make a vertex group, weight paint the body and face different weights (ie, 1 for the body and, say, 0.5 for the face), then in the particle system tab go down to the weights section and use that vertex group to influence the “Length” of the hair particles.

if you use two particle systems: you’ll still have to make vertex groups, one for the face and one for the body, and set each particle system to have its “Length” influenced by the respective vertex group. Kind of unnecessary unless you’re using two different materials for the face and body.

About the lighter coloring for the face - you can either make two materials, assign the face to one and the body to the other (use two particle systems for this, and set each particle system to use the respective material).

Or if you use only one material, you can UV unwrap the bear, create a new image in the UV/image editor, go into Paint mode in the UV/Image editor, and use Texture Paint mode in the 3D viewport to project paint colors on the bear, and save the image. Then on your one material, add a texture, and UV map the image you painted on to the bear. The particle system will use the colors of the image to color the hair.

lol, yeah what he said.

I found your thread on the bear in your avatar. I really like it, how did you make the fur look so good?

As for everything else, I actually am using vertex groups for the length of the fur, I just haven’t done a very good job on it. I think I am going to go ahead and unwrap and texture him, then go from there.

Thanks :>

Apart from the regular combing, i use a few vertex groups to control the amount of kink/roughness/clumpyness in certain areas:

http://www.pasteall.org/pic/show.php?id=13146

Another important part is to include at least one spotlight in the scene - only spotlights can make the hairs cast shadows. Here are my settings:

http://www.pasteall.org/pic/show.php?id=13147

Buffer size is quite high (2048), and it slows down the render a bit, but it eliminates hair shadow flickering during animation. I checked the Big Buck Bunny files, and they have it set even higher than that… I also learned it’s good to have the model scaled to real-world size (for example my bear is exactly 1.80cm tall) - this prevents weird stuff from happening when you’re using Blender Units in the strand settings, which is preferred. Here are the material/strand settings:

http://www.pasteall.org/pic/show.php?id=13148

For the mesh you need to have two materials - one for the mesh and one for the particle system to use. Oh yeah, and last but not least - textures that use photos make fur look more realistic compared to “single colour”. I took some fur from this photo and made the texture with it using projection etc. MorgueFile.com is a good site for stock photos, because the licence permits you to use them for anything.

By the way you reminded me to update that thread…

Wow, thanks for all the help. Now I just need to sit down and really get down to some fine detail work. I can see in your picture that your weight painting has a lot of detail and is very specific. As you can see in my picture, I tried to use a tip I picked up from Andrew Price about making the emitter solid black to “fake” shadows. Now I realize that he was making grass, and it is not quite the same. It turned out better in some of my previous attempts at it before I was done modeling, take a look. I like how those looked better because they were more rough and realistic, aside from that poor combing job on that one. I don’t know what happened there. I guess I am just going to keep working at it, thanks for the advice!

Attachments



Hey, i havent thought of the “emitter to black” trick, it seems to work in some cases.

I can see in your picture that your weight painting has a lot of detail and is very specific.

It was mostly random brush strokes, after which i decreased weights for the areas where it was ugly…

I like how those looked better because they were more rough and realistic, aside from that poor combing job on that one. I don’t know what happened there

Yeah, it’s depressing when you try to comb it and it becomes worse, i had a lot of that… You can enable “Virtual Parents” for child particles which usually smooths out some of the “square patches” that happen in some places. Another way to fix this is to add/remove parents in particle mode while having “Interpolation” on. As for the “dull” look of the second one, you may have enabled environment lighting or ambient occlusion, while the “Tangent Shading” option was set to off. “Tanget Shading” and “Surface Diffuse” are a crucial things to have on, because it shades the hair in a fashion similar to the basemesh underneath, so even point lights will make it look decent! You can read more about it here:

http://www.blender.org/development/release-logs/blender-240/hair-strand-rendering/

Oh yeah, another tip i read from a PDF found Here, is that during the combing stage it helps to set the fur material to full-white with no texture, so that you can clearly see how the hair flows in the render.