Group Object Hair Particles not rendering in normal render?

I have a particle system for grass, which is “Group” under the Render tab and set to a group of grass models that have a material. They show up perfectly in the viewport, but they do not render. At all. I followed a tutorial to try to make it work, copied settings from Youtube videos and other posts here, among other things. Nothing is working and I don’t understand. I can’t find any help on it because everything about hair not rendering seems to be with Cycles.
I quickly tried to render normal hair as well, but that also did nothing. This is happening at home and at school. Blender 2.68a at school and 2.67 at home.

Upload the blend file to http://www.pasteall.org/blend/ and tell us the download link

I have been screwing around trying to fix it, so settings may be changed drastically. Note that it is currently set to path hair, not group object. I do not have blender on the computer I’m using so I cannot change it.
http://www.pasteall.org/blend/25099

You have no materials on your emitting plane. You have the hair system set to use material #3, but there are no materials at all. So add one material, this will be brown or dirt colored for the emitting plane. Then add a second material, green. In the particle system under render set the material to #2. There are other issues but this gives you something to look at. If you change this to use groups, the system inherits (or retains) the material from the objects themselves, so you don’t need to do this. Although you still need at least one material if you are planning to render the emitter, which you will want to do here.


Oh, okay. I was adding the material to the grass meshes themselves. On another note; why are they sideways? I noticed this with normal hair as well.

The other post is still waiting for approval, so I can’t edit it, and thus I will add it here. The emitter object now has three materials, and to be safe, I set the Material in the Particle System settings to 2. Still nothing, though. I have “Material” under the Render tab set at 2, and “Colour” under the Display tab set at Material. Is there something else I need to do?

Here is the scene with some random settings that are probably closer to what you want. Normal velocity controls the hairs standing straight up, or least starting that way. It’s important to apply the scale on the emitter (ctrl-A) Your scale was 23 and that will throw things off in the system. The random setting in the children is responsible for alot of the irregularities of the grass.

I really like this scene concept, with a little tweaking of your materials and the system I think it could be a great work of art.


Thank you, I tried to figure it out and I thought it might have had something to do with the random stuff. It’s actually just a scene for a small project where we set two boxes (I went a bit further with rigs) in combat. I hate to ask more stuff on this thread, but is there any way to “fake” the rendering of the ocean over a large area? I don’t like repeating it so it has 2.79 million faces…

Also, where would I change the size of each strand? I seem to have lost that option.

How large an area are you talking about?

An ocean sim has a resolution parameter by which a single ocean tile can be quite large.

About five times the x and y parameters of the island-thing you saw that has the hair.
Remember the strand size thing, if you don’t mind.

  1. Are you going to ultimately be using Cycles or BI?
  2. Strands (Path) – or Objects (Groups) for the grass?
  3. Are you using an ocean sim, how are you making your ocean?

Probably just normal render, not cycles.
If I could get Objects (Groups, yes) to work, then that.
Ocean sim. Animated.

Cycles strand setting are at the bottom of the hair system, root and tip and of course the hair length at the very top (advanced must be unchecked to see it)
Here is an single ocean tile about that size. The scale doesn’t look quite right, but with some tweaking you might get what you’re looking for. It renders in 5 minutes at 200 samples on cpu. Off to sleep. :spin:


Hm, okay. I’ll give it a shot.