GroupPro, group instances made easy

commercial
add-ons

(JoseConseco) #41

Black friday sale forGroupPro; 40% off so it will cost you 24$


(jachtarfranko) #42

Thanks, i was waiting for this a couple of months and finally bought last week :frowning:


(JoseConseco) #43

Sorry to hear that, but I mentioned it twice on previous page - that there will be black Friday sale. I will donate some % from sales to Blender Foundaton, so you know You are supporting them too.


(jachtarfranko) #44

Its very good for organizing big scenes, the only problem i have , there is not very good compatibility with asset manager plugin.
Grouppro is null object and this cannot be easy added into asset library and after importing from library it is twice.


(maraCZ) #45

Have you tried to use the button called Initialize Groups? This might solve the problem.


(jachtarfranko) #46

Yes, thanks, button “Initialize Group” solves problem. But the firs problem with adding null object (grouppro) into library is still there.


(JoseConseco) #47

I guess I could ask developers of asset manager for integrating GroupPro, if more people are interested. For now the only workaround is to using printscreen as icon for asset.


(jachtarfranko) #48

GroupPro test .blend (129 KB)

Please try ask developer pitiwazou, it would be easy to fix this, I think…
Selected Grouppro+normal object together can be added into library,
Grouppro object alone cannot be, it have no sense.

Second thing, I have problem with copy and paste into another file.
Try test file please. Select all my objects in file, copy them and paste into new black file.
Button " Initialise groups" dont work in this case.

Thanks


(Pitiwazou) #49

If I understand correctly group pro (I don’t have it) the addon duplicate the objects, combine them and delete the previous objects without deleting the datas.

If it’s correct, we cannot know witch datas we need to keep in the asset scene.
AM remove the fake users and orphan datas to avoid issues.


(jachtarfranko) #50

There are 2 problems:

1 adding to asset library
2 twice object after pasting from library

The first problem is on the screen:


Second problem could be solved by " Initialise groups" button


(obsurveyor) #51

Just picked this up and I was reading the release notes: 1.09 works with Blender 2.77 correct? Also, a small thing, your init.py doesn’t have the correct version, it says 1.0.0.


(JoseConseco) #52

Initialize is indeed fixed.
I have sent pitiwazou an info how to path AManager so it should support GroupPro, but I’m not sure if this is so simple… it may require more work.
obsurveyor - I updated info on gumroad because it was wrong.
GroupPro 1.07 - latest version working with blender 2.77 (wont work with blender 2.78)
And yes - version info in addon is wrong (I alway forget to update it :confused: )
Basically if zip file is named 1.09, then addon is in version 1.09


(obsurveyor) #53

Where do I get this? It’s not present in the gumroad downloads.


(jachtarfranko) #54

Initialize is indeed fixed,
Copy-paste, Link, Append big scenes from another files is without errors now.
Works really really good :slight_smile:


(JoseConseco) #55

I modified Matalogue to work with group instances. You can grab fork from here. Hopefully author of this addon will merge this into master.
https://bartoszstyperek.files.wordpress.com/2017/03/2017-03-25_18-51-18.gif?w=480&h=360&crop=1
Also in latest version of GroupProI fixed hotkey not being saved correctly.


(fiendish55) #56

I think its way too expensive for a blender addon. I could support but my max pain limit is 15€ and for that addon must be pretty much no brainer in value to my workflow.


(shevchenkoserj) #57

i am used pivotpro, but after disabing or enabling it in preferences crush my blender:(


(colkai) #58

Just bought the addon to use with HardOps, looks like it is very useful for that situation.


(dezet) #59

Does groupped objects and subgroups can have their own modifiers?


(JoseConseco) #60

No really. The objects inside group are replaced by empty (with dupligroup setting) - and blender don’t allow to add modifiers to empties.