Grrr . . . normal/spec/etc maps perfect in Material Preview, flat when rendered.

I’ve been testing out Insane Bump (a more sensitive and better, free alternative to CrazyBump), and the maps it generates are spot on, but there something stupid going on in Blender! Whenever I use a displacement map, specular map, normal map, AO map, etc, it turns out just fine in the little preview you get in the material buttons, but when rendered, it’s just damn flat. The only map that’s shown is the diffusion map. Normal map, specular map, AO map, and displacement map are excluded. Attached are the two comparisons and the .blend is not uploading for some reason :confused:. I used crazy specularity on purpose, to show the normals in preview. Is this a bug in Blender or something wrong with my graphics card, or am I missing something?

Attachments



Without seeing the rest of your material settings, helping you out here is gonna be tough. If you cannot upload a .blend somewhere, perhaps you can upload a shot or two of your Material buttons?

can you give a link to the program? i’m very interested in trying out.

try enabling texface in, i think, links and pipeline

But I have no UV image . . .
Well anyways, I finally got it to upload, and have two other examples too! No stealy! I’m using these for a game.

Mediafire Link to folder

Think I found the problem, you have your normal map set to “Tangent” in the texture buttons. I don’t know what the correct setting should be; but when I changed that, it made the normals show up.

Yeah, but it should be on tangent, because that’s the type of normal map.

UV map it and subdivide, either with Subsurf Modifier or W => Subdivide Multi.

Ok, but I think I’ll eliminate the displacement, it wouldn’t show up with GLSL, and I can save polies!
Lemme try the UV map thing . . .

You should UV map your normal map texture… Then everything is correct.

It works! Thanks! That makes sense, since tangent is the parameters I specify . . .