Grungit : 1-click wear and tear for Blender

Good to hear!

1 Like

Recently purchased Grungit but can’t get it to work in the version of Blender I wish to.
Using newer version through ecycles, 2.83.5, but it crashes upon click of anything with Grungit on it.
Am I just too ahead of the curve? lol

1 Like

Hi Robert,
Someone else reported the same issue, Blender E-Cycles crashes as soon as you apply Grungit, and it looks like it’s from E-Cycles end for now.

From the Gumroad page of E-Cycles:

Known Limitations of the RTX version:
Raytracing nodes (Bevel and AO)

Grungit uses the Bevel, AO and baking only when you apply it for the first time. Once it’s done and the texture is generated, you can use models that have Grungit applied with E-Cycles without any issue.
I recommend opening the model in official/daily blender Builds, apply Grungit, then bring the model back to your scene in E-Cycels

There is a similar limitation with OptiX in the official builds where it throws an error if you use AO, Bevel or try to bake. I made a workaround that switches temporarily to CUDA and then back to OptiX once it’s done. However I am not sure it’s possible to do that with E-Cycles, I presume the backend is changed so much. I don’t have a copy and cannot test it myself.

Your quick response is appreciated.
It is as surmised. I will let them know. (Thought I saw the guy here…)

1 Like

I previously reported here some issues, but I got swamped with a project and wasn’t able to follow up.

I have installed the newest version of Grungit. Baking does not complete for me. I am currently baking a helmet mesh at 1K. It bakes everything except one corner of the texture. Upon finishing, Cycles will no longer work. It just says “Cancel” in the corner of the screen. Below are the texture and a screenshot of how it looks in Eevee (which is the only way to preview it).

EDIT: I should note, I only ran into this issue after the first update that added baking of details from the mesh normal map into the Grungit maps. Before everything was working fine.

EDIT 2: Switching to CPU rendering allows it to work in Cycles, and switching back to GPU rendering breaks it again. I have a 2070 Super, so memory issues on a tiny helmet file seem out of the question. I have no idea what could be causing GPU rendering to just cease functioning like this.

Another thing to note. I tried just baking in CPU only mode to see if that would allow the bake to finish, and instead it crashes every single time.
TestHelmet.blend (1.3 MB)


Can you try with “(re) create normal maps” enabled? it seems to work fine for me. I have an RTX 2070 as well.

I will try and fix the issue properly ASAP.

That worked. lol. Didn’t even think to try that.

So, it’s only baking on the original mesh UVs that is broken then. I typically like to use the UVs on the mesh, if they have them, since they are way better than auto UVs. I can deal with this until you manage a fix!

1 Like

Honestly I have no idea why it’s broken with this model specifically. I tried other scenes and I could barely make blender complain a little bit when “(re)create uv maps” was disabled (the uv mapping node explicitly sets UV to “Grungit”, even if it didn’t exist. Normally this means it would fallback to the default UV channel).
I made it so it doesn’t create that UV map node if “(re)create UV map” isn’t selected, thinking this would fix it, but apparently that wasn’t the issue. can you still test 1.8.2 and see if it works without changing the settings?
My guess is that it has something to do with the model itself, like a corrupt texture, UV data, normal data, vertex data…etc. Something deep withing Blender’s code that breaks the Cycles kernel when it encounters the complex baker node. Unfortunately the error codes don’t help me a lot.
If this is the only model you encounter issues with, just proceed with CPU baking. Otherwise let me know so I can have more examples to study and experiment with.

Tried it with 1.8.2, same result and crashes most of the time with GPU and CPU rendering.

I did some research and it seems like many addons have the same problem

Also the same issue has been reported on

And I also get the same error with HardOps, MeshMachine, DecalMachine (this one makes Blender crash immediately after I open certain files), and BlenderGIS.
I am not sure if it’s a bug in Blender or just an API change. For now try using the official 2.82 builds to prepare your models if 2.83 crashes

Indeed. I am currently using 2.82.

1 Like

Upon further use today, the baking issue is not just a problem on that helmet for me. It extends to other meshes in my scene, even in a completely new project. Of course as long as Recreate UVs is toggled it works, otherwise no dice.

I fixed the crash issue with newer 1.8.3 version.
In case anyone is interested, Blender now checks for whitespaces in enum identifiers and doesn’t allow them, that’s why it crashed often. Just replace the spaces with underscores.


quality: EnumProperty(
        items=[ ("Medium", "Medium", "m"),
                ("Very High", "Very High", "vh"),
        default = "Medium"

the line

("Very High", "Very High", "vh"),

should be

("Very_High", "Very High", "vh"),

I’m still working on the baking bug without recreate UV’s being toggled.
What kind of models does it happen with? From what I can tell the helmet is exported/extracted from another software or game/game engine. Are the other problematic meshes similar?

Edit: The crash was a bug in Blender and it’s fixed in newer Blender 2.83 builds. Enum identifiers can contain spaces in BPY now.

1 Like