GTX 570 Direct Cut II, CUDA GPU rendering on Linux.


I’ve tried everything on Ubuntu and Mint, I can not run CUDA correctly.
Download CUDA 1Gb not active. Install Blender from repositories not active. Install full driver hangs the machine. I have made many tutorials.

If you recognize CUDA if I install nvidia-cuda-toolkit and run with “sudo” version 2.69 of Software Center. And the downloaded version 2.75, installing nvidia-modprobe, but… They do not support many textures (less than 200Mb). Windows 7 version works perfect and supports nearly 1GB of textures.

My computer Core i7, 8GB RAM, GTX 570 DCII currently running Linux Mint 17.2 Blender 2.69, Driver 346.72

I hope any help, best regards.

Alex. :slight_smile:

I have a serious problem. There are 8 machines for animation production in an environment of free software. Linux, Blender, etc.

I have 7 months looking solution. I wonder if you have a solution, no solution, I have to buy new GTX, with another distro work, I have to use Windows.

I’m no computer expert What do I do?

I just installed Linux Mint 17.2. driver 331

Hi, some point to know:
Blender from repositories does not support Cuda.
Driver from repositories does not work out of the box.
You don´t need Toolkit for Blender Cycles Cuda at all.

How many VRAM your GTX 570 have?
Can you explain the “texture” problem a it more?
What do you meant with “computer hangs”, xserver does not start?

If Windows work out of the box why not use it, Win 7 Pro 64 cost 20 € for 1 license.
Or hire a “Linux expert”, maybe there is a Linux user group in your town.
I think I could get it to work in 30 minutes on a fresh system, no matter which distribution

Cheers, mib

Did you try to install nvidia-modprobe.

Hi, mib2berlin SrecloMicic. Thank You.
I excuse me along. And google the English :slight_smile:

Blender 2.69 if it supports CUDA. Install nvidia-cuda-toolkit (#sudo apt install nvidia-cuda-toolkit) Start Blender as root from the terminarl ($sudo blender) Toolkits need for version 2.69.

1280Mb: GTX 570 Direct CU II

An error of several: CUDA error: Out of memory in cuLaunchKernel(cuPathTrace, xblocks, 1, xthreads, ythreads, 1, 0, 0, args, 0)

“computer hangs”: I download the driver from the nvidia site and installed according to instructions.

All my computers have Windows license. The intention is to create an animation studio completely free and open source software.

If there are experts, in fact I’m doing an animation for a very famous group (CNSL). Apparently the problem is Ubuntu permits. to search the internet you realize that there are hundreds. But I come to seek help from professionals. Specialized.

I have installed the new system, Mint 17.2. Nvidia 331 113, Blender 2.69 from repositories. Blender downloaded from the official website.

Blender runs CUDA as administrator (sudo blender).

  • 2.69 + nvidia-cuda-toolkits.
  • Blender downloaded from the official website.

Mint does not have the 17.2-modprobe nvidia package and is not necessary.

CUDA capacity in Linux is very low, while Windows loads in complex scenes +1Gb of VRAM, Linux is no more than 300Mb VRam.


I see 2 problems here:

1: Install at least NVidia 346 ( included in cuda toolkit for example ) for best performance.
The deb is also a bit easier to handle than the runfile from the driver only install.
Note: i found 346 fastest in openCL usage, 352 is 10 - 20% slower. Cuda performance seems same.

2: You should get blender 2.74 or higher to have all new gpgpu developments, 2.69 is too old.

I use this combo on Linux Mint 17.2 Rafaela without any problems, also no root necessary.


Hi AlexB3D, it is really a bit hard to understand you. :slight_smile:
What driver and Blender version work for you in Windows?
There should be no difference in memory usage between Windows and Linux with Cuda.

Cheers, mib

is Nouveau removed and or blacklisted ?

was the boot image rebuilt after removing or blacklisting Nouveau ?
was 1 and 2 done BEFORE you installed the ?
( been using the .run driver for almost 10 years )

was a kmod-nvidia from the repos used ( i use redhat based systems mostly )

switching from the DEFAULT installed OPEN Nouveau driver to the CLOSED binary blob from nvidia ,
takes more work than JUST a few mouse clicks .

seeing AS you did install the not needed CUDA SDK
dose IT work?
as in did you build the TESTS and run them
the examples are in the current sdk

cd /To/Your/Install/Location
cd /samples/1_Utilities/deviceQuery/

dose the installed cuda IDE “nsight” run? ( cuda version of Eclipse)

and is the /SDK/install/location/CUDA/lib64/ in the system $PATH ?

and you should NEVER!!! need to run blender as ROOT
that is a number #1 big NO-NO

Hi jensverwiebe.
I installed the latest driver from the nvidia site and not working.
I installed Ubuntu 15.04 with the final driver. 346 and not working.
Blender 2.75a have downloaded from the official website.

Hi mib2berlin
I just want to know how to use CUDA on the computer. Simply.

Hola YAFU.

Solo comento la versión 2.69+tookit para aclarar que he intentado todo, pero yo no lo utilizo así.

Eso que me estás diciendo es exactamente lo que hago:
Instalo Ubuntu, actualizo y reinicio, instalo driver y reinicio, instalo nvidia-modprobe y Blender desde el centro de software y reinicio, me bajo la ultima versión de la página y funciona el CUDA, el problema es que no tiene capacidad, en Windows soporta escenas complejas de mas de 1Gb, el Ubuntu no pasa de 300Mb. (abajo te dejo una cáptura)

He hecho de todo, he seguido muchas guías, descargado el driver desde nvidia, el cuda desde nvidia, instalado el driver desde el repositorio, descargado Blender, instalado Blender desde el repositorio, etc…

No se si será por compatibilidad, en la versión 12.04 funcionaba perfecto y mucho mas rápido que Windows, el problema empezó en la 14.04,

Voy a hacer lo que tu digas, Quisiera usar LTS para evitarme precisamente esto en medio de una producción, pero si me recomiendas utilizar la 15.04 lo voy a hacer, en serio necesito que funcione CUDA, es un ahorro en renders del 70% y son muchísimos fps ó a lo mejor mi tarjeta no sirve con Ubuntu actual, Blender y CUDA, ahí si tengo problemas :frowning:

Te dejo está captura de un trabajo en proceso de arquitectura, fíjate que no carga ni siquiera una parte de los muebles y esa escena tiene varios muebles, plantas, focos IES, un entorno HDRI, y los materiales están full, no pasa de 300, y en windows agarra todo por GPU y son como 1.12Gb:

¡¡Muchas gracias por contestar y la atención!! :wink:

Hi JohnVV.

I installed the Nvidia Driver downloaded from the official website, in version 12.04 works perfect in 14.04 up giving problems.
I installed the driver from the PPA (ppa: xorg-edgers / ppp) and fuciona well in Ubuntu 15.04. It does not work in Ubunt Mint 14.04 and 17.x
I do not want to be doing this, I have months trying to make it run, I followed several guides, tens. and I’m tired of reinstalling, download, to do, to undo. For something that should be installed and operated.

I do not want to use Windows, or 3DS Max, or anything proprietary. The driver nvidia obligation. I want an environment free … If I could I buy Xeon servers :-/

I give you a hand, forgiveness is not much English. I recommend you have installed

  1. -nvidia 346.
    • The file “NVIDIA CUDA 7.0.28” 1.5gb downloaded.
    • Give permits.
  2. -install “.deb” downloaded.
    • After the installation close the installation window.
    • Will the Synaptic your browser window type “cuda 7” and proceed to install “CUDA Toolkit 7.0 meta-package” warning.
      Probably prompted to install more things and some time later in my case it was already installed, 8192bits to install. Surely you install 1.5GB. After that if you want you can proceed to upgrade to a newer nvidia version. I recommend reboot. My operating system “linux mint 17.1”. gtx 970 gpu, Good luck.
      You make a video is in Spanish but can be good guide.

Hello. cusa123

I followed the steps. No CUDA.
If I run as root (sudo blender). If you have CUDA.

The same problem, does not exceed 300Mb. VRAM.

Read the private message I sent you.