GTX 850M not in CUDA Kernal?

Okay so I looked around and found out that the 850M isn’t in the standard Kernels used by blender. I read that the sm_50 kernel should fix it so I added it to my scripts/addons/cycles/lib directory.

The cycles reference image starts building BVH files or something but I can’t see what the error is in that one little line there at the top of the render screen. It has something to do with CUDA or some such.

So two questions:

  1. What the heck is that single little process line at the top of the render window and how can I make it bigger or dump it to a log of some kind so I can actually figure out what’s actually happening??!?!? (Where it says Frame 5)


  1. Any suggestions on what build/Kernel or what have you I need to get Cycles GPU rendering to work with a GTX 850M?

Hi, since Blender 2.71 sm_50 is supported and GTX 850M is a sm_50 card.
You should try the latest Blender.

Did you enable Cuda in User Preferences > System?

Cheers, mib

Yep. Totally did the user preferences system thing. I tried it without the sm_50 file and it kept saying card not in Kernal. (Again what is that little line in the picture so I can attach a screenshot/log?!)

Hi, found your thread again, on windows is a “Toggle system console” in Help or Windows menu.
There are error messages or you start Blender from a CMD/Dos Shell.
In Help menu it is also “System Info”, it creates a .txt file.
Open it in Blender text editor, there is info about driver and so forth.
Apropos Driver, do you use latest version?

Cheers, mib

Thanks!

So I uninstalled everything and loaded a pure vanilla (I had a Graphicall build) version and got it to work after enabling GPU rendering. So it looks like I picked a bad build. Thanks again on the error messages help!