GTX 860M no GPU render option. GPU not detected


No CUDA / GPU option in preferences in blender. Blender does not recognize GTX 860M under Linux Mint 17 (Ubuntu 14.10)

OS: Linux Mint 17 64bit KDE
GPU: NVIDIA GTX 860M hybrid
Driver: NVIDIA 340.32 drivers and NVIDIA X Server settings with (PRIME) settings set to force the GTX GPU as active.


SOLUTION: Install CUDA Toolkit 6.5

$ sudo apt-get update
$ sudo apt-get upgrade

Download CUDA 6.5 at

For Mint 17, 64 bit get cuda-repo-ubuntu1404_6.5-14_amd64.deb

$ sudo dpkg -i cuda-repo-ubuntu1404_6.5-14_amd64.deb
$ sudo apt-get update

Now install CUDA

$ sudo apt-get install cuda

Reboot and check driver installation with nvidia-settings utility

Environment Variables

Add the following in the .bashrc file of your home folder

export CUDA_HOME=/usr/local/cuda-6.5

export PATH


What blender version are you using? have you tried a buildbot? (

2.71 and I downloaded it via $ sudo add-apt-repository ppa:irie/blender

I’ve also tried using the download package from, same thing…

Other things I’ve tried:

  1. using various other driver packages (331) (337)
  2. Also installed CUDA Toolkit - sudo apt install nvidia-cuda-toolkit

This also came back:

dkms status
bbswitch, 0.7, 3.13.0-24-generic, x86_64: installed
nvidia-343, 343.13, 3.13.0-24-generic, x86_64: installed
virtualbox-guest, 4.3.10, 3.13.0-24-generic, x86_64: installed (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!) (WARNING! Diff between built and installed module!)

neither buildbots had any change… I’ll just keep trying different drivers I guess. very strange.

I have solved this problem… I will update the OP with what I did.

Thanks for the help

Thanks for this, Trashking. Worked for me!

The problem with NVIDIA DRIVERS 331 and BLENDER is described here

SOLUTION is installing another package:
just type “sudo apt-get install nvidia-modprobe” in terminal …

Note: Without this package only root-privileged applications can use CUDA …

There is another way to work CUDA. You should install Nvidia driver manually from Nvidia official website.

The full instuction is here

The OP solution didn’t work for me, since installing Cuda 6.5 or higher requires (at least in Ubuntu) to install nvidia-346, which got me a black screen and I had to downgrade back to nvidia-331. Installing modprobe also didn’t work, but

Downgrading all the nvidia-331 packages from 331.113 to 331.38 did the trick. To do this in Ubuntu, go to Synaptic Package Manager, find the nvidia-331 packages (in my case nvidia-331-uvm, nvidia-331, nvidia-opencl-icd-331, libcuda1-331 and nvidia-libopencl1-331), select each one of them, go to Package>Force Version and apply it. Be careful though, as the package manager may make you update the packages again, so every time you downgrade, lock the version in Package>Lock Version.

Anyway, do this at your own risk, since the other solutions didn’t work for me, this one may not work for you as well.