GYAZ Export Tools (Seamless Blender To Unreal 4 (FBX))

Thanks for your help, this is now ‘almost’ working for me and I will post a bit about it in the the UE4 forums…

Updated for Blender 2.80.

1 Like

thanks for your hard work! Is it possible update “GYAZ-Handplane-Bridge” for 2.8 ?

I’m updating everething this week.

1 Like

Cool,big thanks!
By the way , GYAZ-Texturer will be back?

No, it remains private for now.

Try this, if you need pbr baking: Principled Baker (for blender 2.8 and 2.79) (bake PBR textures from Principled BSDF nodes).
(I’ve never tested it.)

thanks for your advise!

Thank you for the tool and all the hard work.

I’m trying to get my first character into UE4, Character modeled in Max then using your tools appended rig I adjusted the bones size to match my mesh followed by weight painting in blender. When I attempted exporting/importing… exporting from blender appears to go smoothly but when I import the fbx into UE4 I get the “Cannot merge bones” error then the list of detailed errors that are reoccurring for the most part. (ill attach some screen shots)
SSImp1.bmp (2.8 MB)
SSImp2.bmp (2.8 MB)
SSImp3.bmp (2.8 MB)
SSImp4.bmp (2.8 MB)

When I test the engine after the import UE4 just crashes.

I’ve attempted appending the mesh as a debug without adjusting the rig at all and get a similar error…

I have no custom animations yet, additional bones, IK systems, or custom collision objects/mesh.

Guessing that I’m missing a step or didn’t understand something. (am I right in assuming the default animations should work with this rig or will I need custom animations? Could the auto generated collision mesh be the issue?)

I’ll go back and read over the OP again and check out any tutorial videos posted.

The 4th image shows that you’re not really using this addon but this one: [Addon] UE Tools

woops :pleading_face:
wonder how that happened. had your’s book marked, but it’s been awhile since I started.

Great add-on, I really like it, thanks for sharing! Would it be possible to add the possibility to export fbx meshes to a subfolder like it is for textures?
I like to have the blend files then the exported meshes and texturee in separate folders next to it.

Added the ability to define a subfolder for meshes just like for textures and animations. Location: Preferences > Addons > GYAZ Export Tools > Texture/Animation/Mesh folder. If left empty, no subfolder is created.

1 Like

Thanks for the great support!

I am working with extruded curves to creave walls for instance, but your script won’t export them as they don’t have UVs. It throws an error:

Traceback (most recent call last):
 File "C:\Users\Shapefarm\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\GYAZ-Export-Tools-master\main_op.py", line 1899, in execute
   checks_plus_main ()
 File "C:\Users\Shapefarm\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\GYAZ-Export-Tools-master\main_op.py", line 1785, in checks_plus_main
   safe, image_info, image_set, lod_info, lods = content_checks (scene_objects, meshes_to_export)
 File "C:\Users\Shapefarm\AppData\Roaming\Blender Foundation\Blender\2.80\scripts\addons\GYAZ-Export-Tools-master\main_op.py", line 1494, in content_checks
   for index, uv_map in enumerate (obj.data.uv_layers):
AttributeError: 'Curve' object has no attribute 'uv_layers'

Would it be possible to convert curves to meshes and create a UV map during the export?

Thanks!

Fixed it .

1 Like

Hey guys, Im to noob or what?

Can`t export because of that, and if i change to relative, i get an error.

Any idea?

Had the same issue a few days ago. If I remember correctly the solution was to copy-paste the path by hand and to get rid of the //…\ in front.

@helluvamesh This addon looks great, thanks so much for your work. I looked into it because we failed to import a very simple rigged object into UE4 properly using the default exporter. Root bone / armature confusion etc., these are things that were actually much easier with 3dsmax back then. I still haven’t figured out how to do it properly, need to try some more. It seems like there are lots of things that can go wrong during the process. Maybe I will ask for an easy step-by-step guide later. :wink:

Always give the exporter an absolute path. Uncheck ‘Relative Path’ in File Browser settings when selecting an export folder. By default Blender uses relative paths, you can tell Blender once and for all to use absolute paths in Edit > Preferences > Save&Load > Relative Path (uncheck).

If you want to export in a folder next to the .blend file, set the Destination mode to ‘RELATIVE’ and set a folder name.

In the latest update I added a warning message to remind you to use an absolute path instead, if a relative path is detected.

If you wan’t an actual bone to be the root bone, set Export Bones > Root to “Bone: root” and make sure to name the root bone “root”. By default it’s set to “Object”, which means a new root bone is created using object animation at the top of the hierarchy.

If you define a list of bones to export instead of exporting all bones, you don’t have to include the root bone in the list, the root bone is always handled according to the above setting.

Ty guys, but none of the solutions worked.

I unchecked the relative paths on the preference settings, and tried copy/pasting the path by hand. but im still having the same issues :/, the only difference is that now i get an error too from trying to export as “Path” with the copy/pasted by hand path.

What am i doing wrong?

This is the error im getting now with “Path”:

(The same one i get when i try with “Relative”)

Are you using the latest blender build? According to the error message you’re using a Blender version at least two weeks old. Update Blender to the latest version.

BF changed context.depsgraph to context.evaluated_depsgraph_get() like two weeks ago. (last line)

Until 2.80 reaches a stable release, you should update Blender very regularly.