Hackintosh + GTX460 = Cycles - CUDA

Im on a PC running MAC OSX 10.7.4 (latest) and got my gtx 460 working perfectly, with OpenCL, CUDA-Z recognizes it and all… except for Blender.

The screenshot says it all. Maybe theres a way to force blender to recognize my card as a cuda device, (like its done on CS5) or maybe theres a build from GraphicsAll that can solve my problem.

Thanks in advance :eyebrowlift2:

Make sure your Blender has kernel_sm_21.cubin in /Applications/blender.app/Contents/MacOS/2.63/scripts/addons/cycles/lib

you can right-click on Blender “Show Package Contents”.

Or just download my build, which has it.

If it has sm_21 kernel, try start blender from /Applications/blender.app/Contents/MacOS/blender (just double-click blender there). Maybe the Console gives some information…

Other than that… i’ve the same cuda Driver and GPU Driver Version - this should not be the problem, since here it works. (macbook pro 6.2)

EDIT: I’ve noticed as well that Blender does not show up my cuda card if not enabled on Blender startup (gfxCardStatus)

I Hope this is not a Hackintosh specific issue, since i plan to build one myself :wink:

Thanks man, it worked like science!

Im experienced in CG, but new to blender and I’m loving it this far. The best feature is the blender comunity. :yes:

marking this as solved.

EDIT: your build works just fine, but I think theres more to it than the kernel_sm_XX.cubin files. If I copy them to the official blender 2.63, CUDA still doesnt show up. But your build works, so im using that for now.