Hair baking problem

I tried baking the hair physics. It goes well…

…except in parts where character shakes his head or makes a backflip. Then hair messes up for a while:

Which settings in hair dynamics could prevent this happen?

PS. This is what Gooseberry Branch’s hair shape keys tool could make easier and more flawless.


You need to post a blend file for this.

Controlling Hair dynamics in Blender can be very hard, since for the most part one has very little real control. Once things really start to move, they can quickly start to just fly out of control. About the most you can do is funny enough reduce or minimise the amount of movement, in order to keep it all together. The main settings that control that are the weight on the keys for each main hair particle strand and the Goal Strength.
This does mean that you do also need a fair number of particle keys (vertices or segments) on the hairs, both so that it has more points to interact with to calculate the simulation and so that you can control or limit how much it all moves down the strand. The Root is at value 1, along with maybe first one or two keys near the mesh surface at a high value (like 0.8-0.95), with maybe some lower values as it heads towards the tip, just so you actually get some movement.

You can then increase Goal Strength to help ‘keep it all together’ (values around 1-5 or maybe more can work), and then use Damping and Air Drag to quickly slow the movement down so that it stops.

Generally don’t be surprised if you need to use more then one hair particle system on an mesh, in order to have some sort of control, you may use half a dozen, also, long hair with dynamics, just isn’t something Blender does well, so a modification in design maybe needed.

Keep in mind, that the dynamics sim is only calculated on the main emitter hairs, there is no simulation or testing on any children hairs, but that doesn’t mean use a mass of emitter hairs either, as that will really slow things down and cause other problems.

Also makes sure Quality steps are at least around 10 or maybe a little more.

I guess I could. Maybe you can adjust the sliders right:
Just don’t do other changes - except if you want to suggest me switching order of modifiers.

Hi Guy,

could you clear the bake and “free your particle edit”… after that enable checkbox “use modifier stack” under both particle “hair” emission settings. I know that this is not funny because you loose the comb and you have to do it again but then it should work.
Problem is that hair simulation needs that subdiv modifier information to work correctly. As soon you change the subdiv level it will destroy your simulation.
Rules for hair sim with subdiv meshes are that you need to check “use modifier stack” in particle settings when you use subdivs. Set the subdivs in preview and render to the same value… then it should work and your comb, hairsim and rendering should look like you did it.

edit^ there are some ways to improve performance and make that hair sims independ of the animation mesh ( in subdiv cases) by creating lowres sculp meshes inside the character. but thats another point… and I dont beliefe thats optimal for hair sims and good quality…good luck.

Tried that now, but it still didn’t help. Then I moved particle modifier behind subdivision one, it only lowered the mess, but it still occured when character made a backflip.

o.k. sorry.

I wonder if adding stiffness helps

Think everything is o.k. leave the modifier stack like it was and your hair sculpting…raise the quality steps under hair dynamics for the “mane particle system” maybe to 10. I see that you did a realy fast animation to the head. thats the reason i beliefe. Sorry for any trouble. I did a viewport baking where everything was good before i answered you before. no idea why it was o.k. If that hair dynamic sim is still not working it maybe has to do with hair edit. btw. that vertex groups for mane do have vertex along the arm. dont know why there is no hair.

I just tried this and it finally sloved a problem. Thanks! I’ll pay attention to those quality steps for now on :slight_smile: