Hair Cards will not get automatic rigging (Bone heat issue)

I accidently lost my horse model and imported it from a backup. Removing everything in the scene including the rig. Saving the blend file for appending the model.

It looked good, except when I try to parent the hair cards onto the rig, they will not get automatic weights. There is ~1600 tris in the hair cards. For both mane and tail. The vertex groups create, but nothing is assigned to them.

I think the automatic weights usually likes the bones to be enclosed in a closed mesh. At least in my experience. You get strange results when bones stick out or mesh isn’t closed…. Like you are experiencing. A good workaround is to build a volume around your hair cards and weight that with auto weights. Then use the transfer attributes modifier to take weights from your hair volume to your hair cards.


I tried that solution, but could not figure it out. I ended seperating the mane from the tail, and discovering the tail was the problem. Weight painting the tail fixed it.

For hair(cards), envelopes work best, IMO.