Hair Combing Problem

Using: Blender 2.59 and Matt Ebb’s 3Delight addon.

Hi, I’m having a lot of problems with hair on my model at the moment, particularly with combing. I’ve been following hair tutorials that make it look so easy, but when I try it everything seems to go nuts.

I can set hair up all right, but when I do, all the hair points in the same direction. In the videos, when people set up their hair, it all points in different directions. This is only a minor thing, but I thought it was worth mentioning, in case that means there’s something wrong with my normals. Even so, I recalculated my normals and that’s changed nothing…

I’m using Vertex Groups to control the hair placement. When I set up Hair, some of the hairs refuse to grow on the top of the scalp, even when I try the ‘Add’ brush.

Next, I try combing the hair. When I do that, the hair disappears as if I’ve used the Cut function. I’ve checked ‘Keep length’ but the length seems to be cut short anyway. The hairs go all over the place in zigzaggy patterns, there’s no way of controlling them. They seem to be stuck in that horizontal pattern.

Irritatingly, I tried it on a sphere and it worked just fine, so it sounds like there’s something Blender doesn’t like about my model. I’ve been making this model using 3 different versions of Blender, could that be it? I had some issues with inverted normals after using the Sculpt function too, but recalculating normals fixed that.

Is it a lost cause? Should I just use polygons to make hair?

Thanks in advance.

[Screenshot 1: All the hair pointing in the same horizontal direction
Screenshot 2: Comb brush acting like the Cut brush
Screenshot 3: Unable to style the hair with the Comb brush; it maintains the horizontal direction]


Particle hair is really too complex to diagnose a problem like this from a few screen shots. Any chance you could post a .blend?

Thanks for your reply. Here’s my .blend file.


girl.blend (1.61 MB)

OK, a fairly easy fix.

First, your normals are a bit goofed up – put your model into Edit mode, select your Scalp Vertex Group, then enable the Face Normals display – you’ll see they are all facing either forward or backward, strictly parallel, just like your parent strands (which are following the normals). This is usually because there are radically different Scale values used on the three axes of the model, which is the case here. So, Normalize your Scale by Apply-ing it to the model (Ctrl+A, choose Scale). You’ll see the strands change orientation as the normals are, well, normalized ;-D.

Now go into Particle Mode, and increase the number of Path Steps in the display (4-6 is usually good), enable visibility of all Keys, and enable “Keep:” for both Roots and Length. Then your combing can proceed more like (here’s that word again) normal.

That seems to have done it. Thank you very much indeed! Was driving me nuts :slight_smile:

Thanks for marking the thread “Solved,” now others will know they can find a solution here.