Hair disappears from the top of the model after combing (PHOTO)

Hi. I have a problem, i was following tutorial about animals fur, did everything like there, but in my case after combing hair disappears from the top of the model and just little dots from this hair are visible, though in wireframe i can see the hair but in solid, texture viewport just part of it visible, in render nothing at all. Please help


Please always supply a .blend file that illustrates the issue with any support questions.
Otherwise you will force us all into a pointless guessing game.

BTW, the fact that you still don’t do screenshots properly doesn’t really help, either…:wink:
I have a feeling I already told you that a “screenshot” doesn’t mean to make a (crappy and garbled) photo of your monitor, but to a) hit the PrtScr key on your keyboard to copy an image of your desktop to the clipboard, b) paste the content of the clipboard into an image editor and then c) save the image file.

On Windows 8 you can also hit the Windows key + PrtScr to save a full-screen screenshot directly to a file without having to paste it into another program first. The file is saved to the Screenshots folder in your Pictures folder.

If you do that, we might even be able to see what you’re trying to show us…:stuck_out_tongue:

ok. will bear in mind next time.
i am going to put blend file right now.

and by the way, another problem i have noticed, that when i am adding the partices, then on the top of the wolf lot less hair than on other parts of the body

and something else, in weight paint mirror is not working

here is blend file - https://www.dropbox.com/s/lg6tz9vxotdiw3s/my%20final%20uv%20wolf2.blend?dl=0

What did you do to that poor mesh? :wink:
Seems you had subsurf and solidify modifiers on it once, but decided to apply them… Why?

The polycount is insane for such a simple mesh.
But I think it’s the applied solidify modifier that causes the trouble here. Your wolf is basically a hollow shell now, as the solidify created an entire inside surface with flipped normals. I guess this confuses Blender when combing, as it can’t decide which is inside and outside of the mesh, so the hair grows inward in places.

Sorry for the mess up mesh :slight_smile: but i have only started to learn blender 2 month ago))

Ok. I have also saved the file where is modifiers, solidify and subsurf where not applied and i tried to add particles to that file, but the problem still persist - there is a very few on the top but a lot of them on other part of the body

i will give you a blend file with modifiers unapplied in a sec

A. Get rid of the Solidify modifier.
The Solidify will create an internal surface, which will also grow hair = hair growing into the inside of the wolf… And each hair growing inside is one fewer hair available for the outside.

B. In the settings for the particle system, check “Use Modifier Stack”:


This will force the particle system to recognize the Mirror modifier.
Or you could apply the Mirror modifier - but only that!

Thank you blender guru :smiley:


there is always problem with this modifiers, they always prevent me from making next step. Sometimes it is not impossible to continue without applying them, but sometimes it is not possible to carry on if you have not deleted them :no: i used solidify only to make jaw of the wolf more thicker, now it is thin and tooth of the wolf are sticking out, so probably i will make my jaw as a separate object and will apply solidify to it:eek: