Hair dynamics too soft

I’ve been trying to fix a hair simulation for days with no success. I use hair dynamics, and no matter what options I set the hair is too soft. I want it to be much more stiff, and bend only slightly when the object moves (but wobble a bit). All settings (Stiffness, Mass, Bending, Spring, Air, Internal Friction, Collider Friction) do nothing to solve the issue.

Here’s a basic example blend where the problem can be noticed. If anyone knows the correct values for the hair dynamics, please post a corrected version or explain what to change.

Change your cache step to 1, change end cache frame to 100. I don’t know, this is pretty stiff. Good luck.

In that blend, it seems that setting Stiffness to a higher value works (1 instead of 0). But in my original blend, setting Stiffness to anything higher than 0.005 causes hair to break, regardless of other values. During any strong movement, hair becomes longer and zigzags all over the screen for a few frames at a time. Any idea what causes that?

I’m a little confused. My file is your file, with more stiffness and a couple other paramters changed.

I re-downloaded your original file. Free bake. Cache step to 1. Cache end to 100. Stiffness to 1. Bake. And it looks fine to me, stiffer for sure. Blender 2.68 Win 7.

??? ??? ??? ???,?????? ??? ??? 9 ??? ?? ??? ???(???)??? ??? !!! ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? ??? !!! ??? ??? ??? ??? ???,??? ???? ??? ??? ??? ???,??? TUMI ????? !!! ??? ??? ??? !!!-------------------------------------- http://www.edu.tuis.ac.jp/~lvt/WEB/bbs/sunbbs.cgi?mode=form&no=7567&page=1 http://www.disaibuke.com/home.php?mod=space&uid=28117 http://7773wan.com/bbs/home.php?mod=space&uid=29074

Sorry, I expressed myself wrongly. I meant to say it happens in my original blend file where I’m doing the hair. The test case I uploaded is unrelated, and it indeed doesn’t happen there. Only difference in my work is that the hair is brushed… not sure if edited hair can break if set to be dynamic and stiff. That blend is larger and more complex, which is why I made a different test case.

If you comb hair, bake it, and then try to comb it again-- without freeing the bake, crazy things will happen. Just click ‘free bake’, comb it, and bake again.

Ok, I managed to modify my test case into generating broken hair. It also happens when hair has no editing applied, so it’s not that either. Apparently, making hair length too short causes it, but in my case I need a length of 0.05.

Here is the blend which contains the breakage. The issue lies at the Stiffness value: Setting it to 0 causes hair to not break, but it’s fully soft. Setting it above 0 causes hair to go all over the place. Can someone fix this blend, and remove the hair breakage when Stiffness is >= 1 without changing hair length? I tried in the original but no success.

Whenever you are doing a hair or cloth sim it is best to have the objects involved at a scale of 1.

These steps work for me:

  1. Press ‘N’ to get the transform properties panel open
  2. Select the sphere, look at the scale (in the panel) – it’s 5.5
  3. type Ctrl-A and click ‘Scale’ Look at the scale now, it’s 1. (The length of the hair will shorten in the viewport)
  4. Free bake
  5. Set Cache Step to 1
  6. Increase the length of the hair to what you want
  7. Set stiffness to 1.2
  8. Click Bake.