Hair Growing Incorrectly.

As long as I can remember, I’ve had trouble with hair. Even before the Cycles rendering engine, I couldn’t get it to grow right, so when I went to work on my latest project and got these results, I wasn’t surprised.
I weight painted correctly, and I set all the settings in the particles panel, but the hair that is supposed to be growing out of his scalp is growing out of his arms as well.
Can anyone offer me some guidance?
Thank you for your time.
Happy blending!


If all else fails:

  1. In edit mode, select all the vertices you want hair to be emitted from.

  2. With those vertices selected go to Object Data, vertex groups. 1) Add a new group (plus sign). 2) name it ‘scalp’ and hit enter. 3) Click ‘Assign’

  3. Tab into object mode. Go to the hair system, down to vertex groups. Select scalp for density and length (at the least)

  4. The hair should be emitting from just the scalp. Change the length, etc…

  5. Click on particle mode.

  6. Select comb from tools panel of left. If you have children hairs, click children checkbox at the bottom.

  7. Comb your hair, by left clicking and dragging. Toggling with ‘z’ to wireframe and back can be helpful.

Once you start combing, you can’t changing the number so parent hairs. If you need to change it, click ‘free edit’ in the hair system. Change your numbers and repeat step 5 onwards.

If you are doing preview render in cycles, make sure you’re in object mode, not particle mode, before viewport rendering.

Play with the deflect emitter value as this controls how far the hair is forced out at a normal vector and ignores combing (like real head hair). You need a proper amount (Which varies) to get the hair right. Change it, then comb.

Thanks, Blenderallday, but that’s what I did, and it always shows up emitting from the arms and ears, though I set the vertex group as the scalp only.
Hasn’t anyone had that problem?

Do a test. With no vertices selected, in vertex group click the ‘select’ button. Do only the scalp verts become selected? If not, there’s your problem. Either you have no verts assigned, or all verts assigned. Redo the vertex group. If that doesn’ do it, post your blend. Good luck.