Hair halts rendering on a particular machine, need suggestions

I have a character with particle hair, nothing special, just a typical Strand Render setup, no hair dynamics at all. I’m currently using three computers to render the frames of my animations using this character, and for two of them, it’s just fine, no probs in the renderings.

But the third machine has a really puzzling problem – when the “parts” of the rendering include the hair, Blender just stops rendering. It doesn’t crash, it doesn’t quit, it just does not render any further. I’ve let the file continue in this state for hours to see if anything at all is rendered but with no results.

The OS is WinXP Home Media, and checking Task Manager I see that CPU usage is maxed, not atypical for when Blender is rendering. Mem usage is less than 1Gb of 3Gb available on the system, so it’s not a RAM starvation issue.

Graphics is an onboard Intel chipset for which I’ve d/l’d the latest drivers, and it performs fine in all other situations, including rendering hair in 2.49b (for Kata). Other models I’ve done in 2.5x (such as Nezina) also render fine, including the hair.

Unfortunately I cannot tamper with the hair on this model since it’s also being rendered on other machines and the frames must match when edited together.

Can anyone suggest why this particular machine has such difficulty with this particular head of particle hair? I’m stumped.

BTW, I’m not using distributed rendering, just launching Blender on all three machines and setting them to work independently on the different camera view that are needed.

Addendum: The character has particle hair eyebrows and eyelashes as well, and they render fine as long as I leave the head hair “wig” out of the render pipeline.

I’ve found that the rendering doesn’t really halt, it just slows down by an incredible factor.

By changing the Render>Performance specs from Auto to Octree 256 + Local Coordinates, and specifying 2 cores rather than depending on auto-detect, I actually had a frame complete rendering – in 3 hours! This compared to 3.25 minutes and 5.5 minutes on my other machines, respectively. That’s a factor of (“Lemme do the math…”) about 36 times slower at least.

Any ideas why this might be the case?

I tried changing the hair material, with little change in the result. It seems to be connected to either the construction of the hair “wig” (since the eyebrows have no similar effect) or the CPU hardware (P4 dual processor), or the graphics chipset (Intel 195G), since these are the main differences between the problem machine and my two others. The problem machine actually has a great deal more RAM than the slower of the other two, so memory resources aren’t at issue.

Ubuntu to the rescue! Or so it seems. I have a Linux boot option on the problem machine, decided to try it (it’s saved my Blender-bacon often in the past), so I fired it up, d/l’d 2.61 for Linux, tried my file and – voila! – renders in minutes rather than hours. All three machines now cranking out the frames. Yay.

Damn you to everlasting perdition, Windows!

But, it must also be a hardware issue, because the problem machine has dual processors, (P4), 3 Gigs RAM, and capable if not flashy graphics, but is still outperformed by an older AMD-powered single-core machine with less than 1 Gb RAM, ancient ATI muthaboard graphics, and running WinXP Home Media Center. The AMD is 64 bit but running under Win32. Go figure.

Haha, yea I now would never dream of rendering a project using a Windows build. I have had so many silly little problems with leaving my projects rendering on windows. I switched to Linux and have never had any problems what so ever.

Glad you got your problem sorted (thats a huge difference in render times), its amazing the problems you come up against sometimes, but nicely done for pushing through.