Hair not rendering correctly?

Greetings fellow artists,
I am trying to create hair for a human I created in MakeHuman. However, the hair don’t render like actual hair, but like 2d spikes of some short.
The hair should look like this (but textured):

And it looks like this (like coloured plains stacked on top of each other):

Do you know what causes this?

What did you use for the material?
With just a basic setting but the length and added the vertex groups…using a Principled Hair Shader in Cycles ( only works in Cycles) I get this quick example…

This is my material setup. Is there anything wrong with it?

I tried your setup and the same thing happened.

No that should get results…but I tend to use the Principled as it yields better results…IMHO

What are your clumping and parting settings?

ahh…Check the hair shape…see if you turned the beginning too high…it should be a low setting say 1 > zero to start…then try lower ,5 to zero for example…

These are the particle settings:


Screenshot 2021-02-12 at 3.08.28 PM

What do you mean when you say the beginning? The Diameter Root?

Mess with the diameter root and tip values and or the diameter scale. The way Blender does it makes little to no sense, but dropping the values or just the scale will fix it.

In my most recent project, I used a value of
Root: 0.1cm
Tip: 0.05cm
Scale: 0.12

1 Like

Yes…It should be ? ok with your setting but if you look at your model scale it is 1.2x1.7 meters…so the Diameter might need to be .01
If that doesn’t work then I would suggest you go in and delete edit…that will bring it back to original shape…and then you can quickly re-shape it back…but only as a last resort…

1 Like

The diameter root is too high.
I prefer to switch Hair Shape Type for Eevee to Strip, so I can see in viewport how the hair shape will look like when rendered (in Cycles).

1 Like

Thank you for helping me out @Magnavis and @RSEhlers! :slight_smile: Which one of the answers should I mark as a solution?

1 Like

You are welcome…just toss a coin for solution! :wink: