Hair particle is black when rendered, how to fix?

I’ve been looking at forums without much progress. I added a material to the hair on my model, but it only renders black. It takes on whatever color the material has in object mode, but not in render preview mode nor when I fully render an image of the model. I’m at a loss on where to go next with this.

I’m not sure how much info you guys need to solve this, but I can give more screenshots of what I have activated if needed. I’m still really, really new to Blender (started 10 days ago) so I’m not always sure what I’m supposed to be looking at to get help or fix something.

I don’t mess around much with blender internal that much but I do see that your light source is turned off which in rendered viewport won’t show. If you turn the eyeball icon on next to the sun lamp does it still render out black? I just did a test with a cube with hair in blender internal and when I turn the eye icon off for viewport view it renders out like what you are experiencing but if I turn it on it shows just fine in rendered view and in the 3d viewport. However if you use cycles it shows no matter what in the viewport just dark until you check the sunlamp on.

Aah yes, I already tried with both the light source off and on to see if that was the reason. ‘v’ I even tried with even more light sources, but it rendered black in all these cases. I will try one more time though, just to make sure - might as well cover my bases over again. I’ll update on what happens more thoroughly once I do. In the meantime, what exactly is “cycles”?

Waste of time. Screenshots only help you to explain something. What is needed is the same that you used to get to the problem. Put a piece of the model in a separate .blend and upload that. Here’s how

Cycles is Blender’s other render engine. It uses a more advanced ray-tracing algorithm to render, but it’s more computationally expensive. It’s capable of more realistic scenes, but render times increase vastly. It also has a completely different material system which is incompatible with Blender Render. You can enable it by clicking on the dropdown button at the top menu bar of Blender (when using the default UI) where it says “Blender Render” and selecting Cycles Render instead. You’ll have to rebuild all your materials from scratch, but objects, modifiers, animations should all carry over fine.

I appreciate you taking the time to explain what cycles is.

Actually, I meant to respond to this sooner, but somehow I managed to fix my issue on my own. I’m… not really sure how exactly I fixed it, but it’s rendering properly now so this thread is solved.