Hair particles only have 5 segments

I am using hair particles on a mesh in the current 2.8 blender build and when I use the Add particle edit tool to extrude particles it only has 4 or 5 segments. I have steps at 10 keys at 12, my viewport display and render steps at max and I cannot figure out why it has so few vertices. Any help would be appreciated!

I know it’s quite confusing, in fact, there’s more than one option to control the steps.
I noticed you’re in particle edit mode. You may want to take a look at the active tool options and increase the viewport path steps

That was it! Thank you so much!

Glad it worked :slightly_smiling_face: