hair problem continued weight painting 2.63

still following the tute from http://www.cdschools.org/Page/455

as soon as i set it to hair there is hair everywhere.
so i switch to weight painting and set the weight to zero and nothing happens when i paint the whole thing!

i assume i have to start with no hair and then put hair where i wish
thanks all

Attachments

PARTICLE HAIRPROBLEM.blend (845 KB)

The weights are already 0, so painting them with more 0 equals 0. But actually your brush is set to 0.02459, so you’re painting a small amount of weight all over the model. To remove weights, set the brush to Subtract instead of Mix, and set the weight up to 1. That will completely subtract all weights wherever you paint.

Then under your particle settings, go down to Vertex Groups. Assign your HAIR vertex group to Density and Length. Eventually, you’ll probably want to add children to your hair system. Make sure you use interpolated children when you do so.

the weight was set at 0.02459 to try and reduce/remove the hair that is all over the head.
but i am NOT painting a small amount of weight cos nothing happens.
what am i doing wrong?
does it allways start with hair all over?
thanks

You are painting a small amount, despite your caps lock. You are painting a weight of 0.02459. You can’t see anything but blue in the viewport because that weight is below the threshold of visible heat coloring in the viewport, but I assure you that you are giving those vertices a tiny amount of weight. That is what you are doing wrong. If you want to remove weight, change the brush from Mix to Subtract. If you then set the weight to 1, it will remove the weight entirely (weights are between 0 and 1, so subtracting 1 will reduce it to the limit, which is 0). If you set it to some decimal value between 0 and 1, it will remove that amount.

well thanks
but when i first open the file and the weight is of course the default 1
BEFORE i do any weght painting there is hair all over. is that just the way it is.

As I said above, you need to tell the particle system to use the vertex group. In the file you shared, you created a vertex group named HAIR, but you haven’t assigned your hair system to use it. You’re doing all this weight painting, but you’re not using the resulting vertex group for anything yet.

At this point, you really ought to just delete that vertex group and start again, since you’ve already painted miniscule weights all over the model and it will take a lot of fiddling around to clean that up. Delete it, then create a new vertex group. Set the weight paint brush’s weight to 0.25 or 0.5, leave it on Mix, and paint only where you want hair to grow. If you need to remove weight from the vertex group, set the blend mode to Subtract instead of Mix. A higher weight will remove more.

i tried painting the whole head with that 0.02459. but the long hairs stayed

so i deleted the vertex thing, painted a stripe with weight thingy then did the hair and see the result
thanks

Attachments


set the brush to Subtract instead of Mix NO CAN FIND

some progress!
on a vertex group thingy i clicked length and it halved the hair length - is that what the weight in weight painting is supposed to do?

Please remember i have NO IDEA what i am doing- just trying to learn by following a tute.

the hair looks clunky!
thanks

Attachments


PARTICLE MOHAWK.blend (1.43 MB)

And did you ever assign your vertex group to your hair system like I told you to do, or are you just painting a vertex group that isn’t set to influence anything?


Here:


Sort of. I always assign the vertex group to both density and length because there are sometimes errors with hair placement if I don’t do both. I’m not actually sure why this is sometimes the case. You’ll actually control the hair length by editing the hair in Particle Mode. Your tutorial should cover this at some point.

I’m seriously doubting the quality of whatever tutorial you’re following if it hasn’t taught you any of these things yet.

The hair is emitting straight out of the faces. Suzanne has terrible topology and not nearly enough polygons for a good hair system. You’ll be able to fix this a little bit by styling the hair strands in Particle Mode, but to get really good results you need a much less crappy model than Suzanne.

food for thought. i need to know how to asign the groups.
it is probably me NOT the tutorial
thanks

Just click in the text box there and it will drop down a menu of every vertex group you have created. Then select the one you want. But it looks like you’ve already done that. This step is explained on page 10 of the Particle Systems chapter at your tutorial link.

To smooth out the hair’s distribution without adding extra geometry, click the checkbox marked Advanced at the top of the particle system settings. Then under the Emission pane, you can set it to Random instead of Jittered, and tick the boxes marked Random and Even Distribution. Like so:PARTICLE MOHAWK1.blend (1.47 MB)

In that file, I also applied your scales and rotations. This is always a good step to take with any model, as it prevents some odd behaviors in a lot of different areas. Go to Object Mode and hit Ctrl-A to apply scales and rotations. This makes its size and position “real” and sets them back to a scale of 1 and a rotation of 0.

Your tutorial link is more like a textbook than a tutorial. I think it is meant to go along with live instructions or presentations, so it isn’t the best source to use as a straight step-by-step tutorial. That, I suspect, is why you keep missing vital steps in this process.

i know i am a bit slow… but i don’t see any hair in the PARTICLE MOHAWK1.blend
thanks very much

also i see the head is NOT affected by clicking solid etc instead of wire frame.

I don’t know why that would be. It’s visible for me.

which version did you use?
here is what i see when i first open the file
2.63
thanks

Attachments


2.68 is out now. You should update.

i have enough problems with this version!
thanks

New versions have bug fixes. You’re usually better upgrading. I have been using more recent versions than you and I don’t have any problems. If you’re having trouble with Blender, upgrading to the newest version should always be your first step.