hair shadows not passing through transparent surface

Hi, after a few hours of search I still did not find the answer so I hope this is a valid question.

Hair (alpha channel texture on planes) casts good shadows on the skull (skin) but those shadows do not get cast if the shadow has to pass through another transparent surface ( another hair panel).

See the problem at


The mesh can be seen at

The eyebrows are textured onto a mesh just above the skin and when the long thin hair casts a shadow on the eyebrow mesh, that shadow dissapears. I want it to fall through the eyebrow mesh and show up on the skin mesh. You can see the shadow reappear below the eyebrows where the eyebrow mesh stops. The same problem appears at the top of the head where one hair panel blocks the shadow of a panel above it. This is actually more serious since I can just make the hair not pass over the eyebrows, but at top of head, it will look bad.

How do I get the shadow of the long hair to pass through a alpha channel of another surface and fall on a third opaque surface?

The shadow light is a spot light with Ray Shadow.
The eyebrow mesh texture is ztransp

Thanks,
john

I suggest using static particles for the hair, that way you can easily have shadows appear.

Does the hair need to move?

As if not cant you put the eyebrows onto another layer and bake the hair shadow onto the babies head (hmm this is the only context where baking something on a babies head wouldnt be cruelty…) then it should show up on the baby.

(Baking the shadows onto the texture is possible isnt it?)

If you’re doing images, then static particles are a good choice, the only reason i’d see you using images for hair is to keep polygon count down or using it in a game engine.

Do you have TranShadow on the hair material?

Hi,

TraShadow should be enabled on the skin material, not the hair material. That should solve the problem.

But if hair objects are over other hair objects you’ll need to push it on the hair material for it (the other hair objects) to get the right shadows.

You should select Transhadow on every material you anticipate the shadows falling on.