Hair shrinks/disappears when rendering baked hair dynamics

When modelling a character with fur, I noticed the that the hair would “disappear”, or more accurately shrink down to a very tiny amount after baking the hair dynamics and trying to render it. The hair is still on the object in the render it’s just very tiny and/or hard to see.

I recreated the problem in a separate file, at first the hair is fine and bakes as normal

Then the render, where the hair has “vanished”

Going back to the viewport, the hair has shrunken down completely and is basically against the surface of the object.

What exactly is going on and how can I fix it? Here’s the blend file, and I’m using Blender version 2.92.
Hair Ball.blend (1.7 MB)

did you click ‘bake all dynamics’? because that usually bakes EVERYTHING, and that fixes a lot of problems with hair and particles.

Clicking on “Bake all Dynamics” does nothing, it doesn’t even start to bake. As far as I can tell, nothing happens why I try to bake all dynamics.

i feel like its more a problem with your computer, i dont think you have any disk space left. this usually happens when i run out of disk space.

After cleaning up little bit, I have ~150GB of space left. Tried to bake all dynamics again, and still nothing. Also tried to bake the dynamics normally, problem still persists.

I don’t know uf the problem was solved but I discovered thd origin of the bug.
If you use negative number as preroll you could have this issue.
Once you start from 0 or 1 is fine.