Hair won't render no matter what I do

I have tried experimental instead of supported, did everything under cycles settings, etc. It just won’t show up in the render result, and when I return back to Object mode, the hair disappears from the view (particles are still there in the Particles panel).

Does this action require more than 2 gb or RAM on the graphics card, or what? I have NVIDIA GeForce GTX 1050.

If the graphics card is not the problem, please suggest a solution if you have one. I’ve tried this three times, and every time the same thing happens. Thank you.

Assuming a fairly simple object and hair, then it should render on the 1050 and you only need supported. Usually if GPU RAM issue, you will be an error, however, one way to make sure, if set hair stands and render settings low and render via CPU, just to rule out the GPU.

That aside, there could be a whole mass of reasons why it’s not showing up, likely the easiest thing to do would be to post the blend file that’s not working. That way we can confirm it’s not rendering and work out why.

Or, load up this file and hit F12 (139 KB) (unzip it first)

All being well, you should see a basic grey hair ball (it takes 12s and 9MB of RAM to render on my 1070 Ti).

If this works, then you know your system and Blender install is OK, which means there’s something you did or didn’t do on your file. Having said that, I didn’t do anything special, started Blender, added a Sphere, added a particle hair to that and then just lowered the emitter hairs down and add some child hairs.