Hair won't scale with object?

So I have a problem where I’ve added a few hair particle systems onto a mesh separate from my main mesh, however when I try to scale the hair object, the hair gets out of control and loses its shape. I’ve tried parenting the hair object to an empty, applying the scale, and I’ve tried disabling hair dynamics, but nothing works! I’d really like to be able to scale the hair object without having to re comb everything. Please leave any feedback you like! :slight_smile: Thanks in advance!

1 Like

Actually, after disabling Hair Dynamics (for all particle systems) it works for me:

For some reason I can’t open the file. But what I don’t get is why mine still gets messed up after I disable the hair dynamics? :frowning:

Tried the file just on a different installation without issues (on 2.80). Should you be on 2.79, yes, then it likely will fail.

One thing I noticed, when playing around with it again, is that what won’t be scaled are any size values in the children settings. In this case the Radius for spreading around the parent doesn’t adjust. Is it that what you mean? Couldn’t figure out an easy way to fix it, either. You could use drivers…

Yeah, basically I just want to scale it as if it had no hair dynamics.

I may have found a solution! I noticed the problem is like you said, the children radius. Now I just have to find a way I can measure how much I scale an object and then apply that to the radius.

Defining a driver for the radius should work to get this.

Cool! Thanks!

This post really helped me. But a few extra steps required for me so I thought i’d share in case it helps others.
Scale your object down and the hair will scale down too, but still looked very strange (especially since i was scaling my character down to 0.1. I also needed to scale down my radius value for the children by the same amount (so radius value *0.1) and also the kink amplitude value if using any kink settings.

Before finding this solution I had spent so long on my character’s hair, i was looking at scaling everything else in my scene(s) up to compensate! - My character was 24m tall!

1 Like

Thank YOU :star_struck:

Hello, I created a simple addon for the use of my co-workers at our studio. Maybe anyone can try it. Basically what is does is, you can divide the scale(x,y,z) of the mesh with a division factor and the settings (kink amplitude and children radius) will be changed (divided with the same division factor) automatically. (Kink amplitude and children radius were the main factors which affected the messy groom in our case). So you won’t need to change them one by one manually if you have many particle systems. The addon is quite simple. So, it won’t fit in every case, but hope this will help someone. Maybe you can modify to suit your case if needed

Download the addon from GitHub