Half of model not getting exported

Hey folks,

I have a model of a robot consisting of multiple objects and an animation. I’m exporting to fbx, but when I do, the fbx output is missing the bottom 2 objects (i.e. the lower half) of the robot. There is empty space where they would have been. I’ve tried selecting everything and then exporting. I’ve tried selecting everything and then choosing “selected objects” from the export window. And also tried a suggestion to renormalize everything. Nothing has worked though.

Any suggestions what I might be doing wrong? If you need any more info or screenshots of properties windows, just let me know.


Finally got it. That was painful, but I’m a newb. After many wasted hours it dawned on me that perhaps I shouldn’t continue to ignore that 1 line warning output from fbx: “Mesh contains vertices with zero bone weights”

Having no idea what it meant, I googled “blender libgdx bone weights” and found a posting where someone mentioned that meshes that don’t have bone weights won’t get rendered in libgdx. I then went back to my original tutorial and found that I could select all my meshes and shift click my bones and then ctrl+p and choose to parent them with automatic weights. Voila, all is now rendered on export.

I guess the warning just wasn’t scary enough and my brain ignored it (after all, we get bombarded with thousands of warnings every year that make complete sense to ignore). Lesson learned. Thanks to all that took the time to read my post though.

So this actually raises a new question. I’m doing another blender model for a house. I have no bones/armature and as a result it doesn’t display in libgdx. What’s proper practice here? Do I add a bone/armature and parent them to my walls, floors and ceiling?