Hallow Cannon

I am making a cannon for a tank. I want the inside of thecannon to be hallowed. However, when I render or import the mesh to unity it becomes transparent from the inside.

Please look at the pictures.
http://imageshack.us/f/826/99951403.jpg/
http://imageshack.us/f/96/60846957.jpg/

From the top it looks normal, but from the front or inside view it looks like vertices are missing. In blender while I am in object mode it looks ok but if I render I get the same problem.
How do I fix this problem?

It could be inverted normals, depending on how the model is made, it could be as simple as selecting the model (in edit mode) and pressing CTRL+N to recalculate the normals.

Now if there are internal faces etc… it could be more long, as it may require you to invert the normal of the faces manually (select a face and Click on Mesh -> Normals -> Flip Normals, there’s a button “flip” in the right panel menu available for that too) to flip the normals that CTRL+N can’t do

Thanks, but it didn’t work.

If CTRL+N and/or flipping normals of the inverted faces do not work , upload the cannon so someone can give a closer look.

TankCannon.blend (399 KB)

I have attached the Cannon. If anyone can take a look at it for me I would deeply appreciate it.

A good method to spot quickly inverted face in Blender is to use Textured view instead of Solid view.
And you will see immediately that your cannon model has indeed inverted faces.

And i notice that the interior and exterior of the canon use the same faces. Maybe Unity does not support double sided faces (i know that some engine does), that could then be why from a side you see the texture and on the other side it’s invisible, i don’t know Unity so i can’t say more.
Blender do not support double sided faces, you need to double that face to imitate the effect (with each faces having opposed normals), there’s a solution for rendering using nodes, but for the case of the model being for a game engine, it shouldn’t have any effect

If it is indeed the case, you would then need to solidify the cannon model by using the solidify modifier and tweak the “Thickness” value of the modifier to get the interior being actually modelled and not using the same faces as the exterior :

http://i.imgur.com/Nf4RM.jpg
to
http://i.imgur.com/9LOiZ.jpg

But that said, the solidify modifer obviously increase the polycount, as it adds additional geometry to the model, so for low poly solution it’s probably not the best choice.
The best solution i think would be to find how to enable double sided faces in Unity (assuming Unity actually support them), if it’s not possible, i think only the solidify modifer would solve your problem.