Halloween horror

Hello,
I am new to this forum and also a beginner in Blender.
I never used sculpting before, so I’d like to hear your advice.

I also have one little question: When I’m in sculpting mode, the head has a lot more details. But when I switch to object mode a lot of details (teeth, scars,…) are gone.
Did I do something wrong? Or does Blender do this because the object is too heavy otherwise, but will render perfect like it should?

thanks, Maarten




looks good man, check the multires buttons for where is says ‘view’ and increase it to the same level as the sculpt setting, which is right next to the view setting.

Awesome! I always get intimidated by multi res sculpting, dynatopo seems more approachable to me, but you did an awesome job here!

Thank you for the tip and the great support!