halo light transmits solid object

I am pretty new to Blender, so sorry if the problem is common and I couldn’t find the solution by myself.
I have an issue with halo effect. It seems that if the halo spot has enough size and is placed just near a solid object (i.e. plane), part of its light is transmitted through the plane. At the moment I try to render a picture where smoke passes a solid pipe, but if unfortunately the smoke (halo particles) “permeates” the pipe walls :confused: … How could I avoid the permeation?
Thanks in advance for any help.

If you can upload an image that would help.

But try taking the halo Bias down to a very low level. That should correct it.

Here’s the picture…
I’m trying to find Bias for Halo…Is it not only for regular non-halo materials? I’m using Blender 2.49b…


Halos dont calculate object intersections (to my knowledge), that is to say that if the particle point is closer to a masking face (i.e. the inside of your funnel) than the radius of the halo (HaloSize), the halo will render outside the face, as is the case with your example. Have a look at the attached image to see what i mean.

All I think you can do to fix this is ensure that the thickness of the walls of your funnel are greater than the halo radius (HaloSize) to prevent the particles from getting close enough to show the Halo through the outer wall. This may require more particles to give you the same volume as you have now.


Many thanks for the exhaustive and comprehensive answer!

Yes. After a few days of experimenting I came to this conclusion as one of two possible solutions. I also found out that the problem can be fixed by using Size Deflect option (Particle Buttons -> Extras -> Size Deflect) where size of particles (this should be set as no smaller than Halo Size) is taken into account in calculating deflections.

However, I would like to see the smoke particles (I now use billboards, but the problem is analogous) size changing in time which would be set by Ipo Curve. In this case if I use Size Deflect some of them which are too big do not pass through the funnel. Thats all right, those particles stay just before the neck region and do not mess the image. The problem is when the smaller ones enter the neck and then overgrow to give very similar effect like in the picture I attached earlier.
I wonder if there is any way in Blender to set the particles (or any other objects in general) not rendered if the particle’s center is located behind solid face. Or maybe the only way is to resign from changing the particles size.
Thanks in advance for any suggestions!