Hard edge issue

Hello all,

I’m having some issue with my topology, I’m just learning Blender as a hobby (mostly during my lunchtime), and going through a character modeling, I’m having a hard edge coming out of nowhere, instead of a smooth topo…
Does anyone have any idea where that might come from?

Thanks for your help!

Do you have Autosmooth turned on by chance? (it’s in the Object Data Properties tab under “Normals”)

Sometimes when that box is checked, you can get random hard edges depending on the Auto smooth angle setting.

Yes it was, but even after turning it off, nothing changed.
I played a bit with the material, and shading. It appears that some normals are in facing the wrong way, as they don’t show when ‘backface culling’ is activated.


I just recalculated the normals, and it’s all good!
Thanks for the hint!

Are you familiar with the FACE ORIENTATION function? It will show inward facing normals as red and outward facing normals as blue.

In blender, I’m basically familiar with nothing, I just installed it 3 weeks ago :sweat_smile:
I’ve been working on 3dsmax before though, but blender being opensource, I could have it at work (not related to 3d at all). So I’m learning bit by bit, doing researches for most things I don’t know
But that’s a great help!