Hard Ops Thread

Is there a function for clean up cutters and meshes after boolean operations?

besides auto hide on next cut there is also this.

we havent yet made apply remove cutters at the same time

Yep , but i mean for HardOps, it would be cool to have some kind of Boolean AutoCleanUP function with two options:

  • Delete(remove) originals (Keep result)
  • Delete(remove) cutters

I`m glad to know that it has been added to the list. Thanks.

Hello, I bought the box-cutter add on from BlenderMarket yesterday and was able to use it with blender 2.8 just fine. However I updated my version of blender 2.8 this morning and now whenever I try and start a cut with box cutter I get a trace back error and blender crashes. Here is a screen cap of the terminal message I am getting

has anyone else encountered this problem or have any idea what might be causing it or how to fix?

Likely the nightly build has changed something, I tend to keep a “working 2.80” and “latest build” folder, once I’m happy everything works, I move it over. That way, if it crashes, I can drop to a prior build and keep working until the addon devs have a chance to sort the issue. Sometimes, they end up having to roll back as an issue is introduced, then the next blender build reverts back. Don’t envy them at all!

Yeah I figured that might be the case, after I had posted I did try using it with the prior blender2.8 version and it did work, guess I’ll just stick with that version till it’s resolved.

Boxcutter and HardOps have been updated for this new depsgraph era.
All markets updated.


Hi @masterxeon1001 - it seems that I’m unable to get the “Step” operator in HOps to work, and it’s giving me major workflow issues. I’m running 2.80 beta dated 2019-05-17 built at 23:36 (I downloaded it this morning 18May2019) and have tried using both the last build of HOps (Californium 26), as well as the build which just dropped an hour ago (Californium 27). After some time away from hard surface modeling, I’m brushing up by following along with your tutorials playlist on Youtube, and the “Step” operator clearly plays an important function. However, it doesn’t appear to be working at the moment, as the bevel operator won’t apply when I select it, meaning that if I try to CSharpen>BWidth>Step>Boolean>BWidth, etc… basically everything messes up after the first BWidth operation. Any ideas what’s going on? Bug? Thanks!

Step isn’t as much a thing as it used to be.
To step like classic it works if you cycle to weight in the ctrl + ~ helper.

Bevels are capable of being stacked via the ctrl + click and ctrl + shift + click bevel modifier in the Q menu as well.

The behavior for step and angle is something we are still sorting out as 2.8 comes into fruition but it should exist as the classic did via weight workflows.

i hope to someday have systems added for promoting booleans between bevel levels and streamline the systems but at this time you are also able to cycle through live bevel mods via shift + scroll during bwidth.


Thanks - these examples help a lot to fill in the info gap I’ve run into while watching the early tutorial videos. Probably, I’ll find that you’ve already covered all these topics in later videos. :wink:

There is no better way to implement this feature than this:

From what I see, it’s ready for implementation.

patch version 30 is very unstable, especially with skin modifier

Looks, like this problem in latest git blender… i don’t know for now

Hi folks,

Sorry - I’m a relative newbie learning about add-ons in general for the first time. I’m doing pretty well with BoxCutter and I got HardOps with it in the package deal thing so now I’m trying to follow along with the manual at:


I have the Q menu though I had to disable the native Q function in Key Bindings. No biggie. I like it quite a bit. The Shift-Q menu looks useful but it’s a little harder for me to grasp. No worries, I’ll keep reading and following along with videos and such.

But I have no T Panel options… or at least as far as I can tell. The only thing on the HardOps rollout on the right side of my display is “Cutting Material -> All”.

The docs I’m reading say that the Q menu does what the T Panel does, and I understand that a lot of this is going to be context-sensitive, but I figured that if I had the T Panel visible it would help me out while I’m taking baby steps. Did I miss a configuration button or something?

Build for both is whatever was available around the first of June. I try to update weekly, but I sometimes fall a little behind.

Screen capture:

As of 2.8 the T panel is no longer a thing. The update log is here.

I would recommend the video content instead of the docs for 2.8 since a lot has changed.
The docs will be replaced when 2.8 is closer to official.

The videos will probably do a little better at getting you up to speed besides the discord and asking questions. The old docs also can work but 2.8 has a plethora of changes from 79. Most for the better.


Much appreciated; thank you. :slight_smile:

One thing that I was glad about to learn from your docs is the evolution of the workflow. I learned the Loop-Cut & Edge Split method first and had trouble with duplicates, just as you did. I didn’t even know Auto Smooth existed until I saw your screen captures. :slight_smile:

getting these errors when trying to activate box cutter in the newest blender 2.8
(gonna have to be in 3 posts since i only signed up today)