Hard Ops Thread

add-ons
commercial

(colkai) #1569

Oh cool, I was under the false impression CSharpen applied all modifiers, (did it used to some time in the past?). Just the job, happy bunny. :smiley:


(masterxeon1001) #1570

no. only specific ones always. The F6 has specifics.
image

Its a tentpole. So it has always had Csharp for that need.


(colkai) #1571

Dang, all this time I’ve been using it. Ya make it too powerful man, too much to remember! :stuck_out_tongue::joy::joy::joy: Can’t imagine working without it :sunglasses:


(masterxeon1001) #1572

the ctrl + ~ helper misc tab is also a party. If you are playing with csharpen try the “jump to bwidth”. It allows csharp to also adjust bevel in the same go.


(Oskarious) #1573

Hi, I am getting some weird results in 2.8 and I don’t know if it’s because I am doing something wrong, or if it’s 2.8 acting up. As an example, c step seem to apply bevels on the already existing bevels.

Subtracting a boolean also just cuts a hole in the mesh and does not fill in the space.

It’s entirely possible I am doing something wrong since I have not really spent any time with 2.8 and am fairly new to hardops.


(masterxeon1001) #1574

this might help
https://hardops-manual.readthedocs.io/en/latest/step/


(Oskarious) #1575

Right, I didn’t realize things had changed in regards to step. I will read up on the docs again, thanks.


(masterxeon1001) #1576

i think to properly diagnose the image we would need to see the modifier stack. From the images. I think you may have bevelled the bevel.

Also the mirroring. Did you use bisect? Because that is no longer recommended compared to “modifier” in alt + X.

In this video I talk about the mirroring modes and how bisect might not be useful in 2.8 compared to modifier which allows for cross axis cutting. I have been enjoying cutting across the mirror axis. So that could be an issue as well.


(Oskarious) #1577

Here’s me bevelling my bevels again https://www.youtube.com/watch?v=5e4BGj1jXW8

And here’s me getting funky subtract behaviour https://www.youtube.com/watch?v=eGke4UuEaiY

And my 2.8 version is from december 22 if that would make any difference


(masterxeon1001) #1578

image

that is bisect. dont use that. We are possibly going to remove it altogether since blender has evolved past it. To the left is modifier. Which should now do better.


(masterxeon1001) #1579

image

in the ctrl + ~ helper you can set the angle in which ssharp/csharp and step catches and bevels edges. Also what mode are you on? From the look of the modifiers I would also make sure the bevel is above the weighted normal.


(masterxeon1001) #1580

now I see what is going on. The angle workflow is not going to work with step.

  • with the bevel mod set to angle it is going to catch every 30 degree edge.
  • in the (ctrl + ~) helper you can choose between angle(new) and weight(classic) the WN button will add a weighted normal at the end of the stack on csharp or cstep(useful for some shading situations)
    image
  • if angle is the workflow step shouldn’t even show in the Q menu because that will cause those issues. (we’ll look into that)

Ideally, when stepping,

  • you have decided to apply that level of bevels and wish to work on a smaller level
  • must be in weight because angle will be too finicky

Sorry for all the confusion on this. I’ll be doing a video on this…
The 2.8 era has had me messing with more nondestructive workflows but this issue is an oversight that we should have considered.

The angle workflow is also fun and nice to play with but its angle based so it limits design slightly. But once you know some rules it can be quite fun as well.


(Oskarious) #1581

I see, thanks so much for the quick help on this! I will for the moment move back to weight workflow for the time being and read up on the new angle one as well!

Thanks again :grin:


(Daniel Bachmann) #1582

Hi there, not a real bug but a notice :wink: when using boxcutter slicing in isolation mode “/”, you do not see the slice unless you exit isolation mode. While working on multiple objects this might get in the way of the workflow.

Happy new year and thank you for producing such high quality addons!!!

Using Blender 2.8 d96596de294e 218-12-30 15:30 and the latest boxcutter/hops


(masterxeon1001) #1583

local mode is not recommended at the moment but we are aware of that as well.


(Daniel Bachmann) #1584

Good to know, thank you :slight_smile:


(Daniel Bachmann) #1585

I am trying a non linear workflow, meaning I still model on animated objects. Yeah, might be not super wise but I wanna try if I can mimik a bit of my Softimage workflow.

Now, I have a rigged Finger and want to use the hops mirror modifier. It shows up in world axis by default. Is there a possibility to set the axis to local?


(masterxeon1001) #1586

we’ll check into that!


(z01ks) #1587

I think there is a bug with the newest Boxcutter or maybe there is a setting I am missing? The Pick Shortest Path (CTRL + Left Click) stops working after I install Boxcutter 7.10. I tried with a couple of recent blender versions.

I believe there could be a conflict between something that Boxcutter is doing in relation to the CTRL + Left Click functionality, because after assigning Pick Shortest Path to CTRL + SHIFT + Left Click it works again.

PS. I think there is no Boxcutter thread so I’m posting here under HardOps.


(Peetie) #1588

I tried that out, but cannot reproduce it with the latest build today. Shortest Path (Ctrl + left Click) is working for me in Edit mode (vert, face)