Hard Ops Thread

commercial
add-ons

(colkai) #1689

There you go man, you needed some rest is all. :wink:
EDIT: Meant to ask, what settings are you using in 2.80 to get that ‘edge shader’ style look to your mesh as you are working? Thought it might just be the valley/edge settings but can’t seem to get my viewport to match. It’s great for definition on the mesh as you build.


(masterxeon1001) #1690

alt + V >> eevee HQ and i just turn off viewport shadows. They get kinda weird sometimes making my meshes look like… bread. haha.


(colkai) #1691

Cool man, thanks for that. :slight_smile: Lovin’ the work on boxcutter. :sunglasses:


(miltron3000) #1692

Do other Mac users have trouble adjusting settings while in the bevel and array modals in BC? I can’t change the segments on the bevel, or the array count during either modal operation. In other tools, such as adjusting the B width, I can use + or -, if scrolling on the trackpad or mouse isn’t working right.


(Rob) #1693

I can’t get the Alt+V command to work in any version of Boxcutter and/or HardOps.
Only have the three top options, and nothing of the extended lower part.

I did check the shortcuts in the keymap, but it looks all is there.

rob


(Bohdan Lvov) #1694

Try to delete startup.blend in C:\Users\username\AppData\Roaming\Blender Foundation\Blender\2.80\config

By some reason it causing absolutely random issues in 2.8 at the moment. I had the same issue and this trick worked.
Also some time ago I wasn’t able to call Stroke menu in Sculpt mode, and it also was resolved by this weird solution.


(Rob) #1695

Well… that’s too bad, as I have a custom startup file running that I don’t like to delete.
I will make a backup and have a go to see if this will solve some issues.

rob


(colkai) #1696

Hmm, odd, I have no trouble using alt+v with BoxCutter in 2.80, what is your system? I’m running Win8.1 on a n i5-4570 with 16GB ram and an EVGA GTX1050ti SC GPU (4GB). This is what I get on Alt+V…clipboard01


(Rob) #1697

ostapblender is right, it is the startup scene that is messing things up :frowning:
I will see if I can rebuilt my startup scene again with all the stuff I have there on running a new scene.

cheers!

rob


(colkai) #1698

Aye, been there, now I have a couple of “empty” scenes I can reload then save as startup scenes. Don’t have to call on them often, but handy to keep. :slight_smile:


(Bohdan Lvov) #1699

yup, you can, but make a backup so some of the new builds won’t screw it up.
Checking “read only” in file properties also might help to prevent this.


(oaschwab) #1700

@masterxeon1001
I just bought the hard ops and boxcutter combo. I’ve been eyeing them for awhile. I’m actually a little too busy right now to dig in but I knew I was going to get them sooner or later. I also appreciate how much you help the blender community. I see you helping other plugin developers all the time. Great work!


(masterxeon1001) #1701

thanks! we try.
dives back into shadows


(yolao) #1702

Hi.

So in Blender 2.8 (that i download last Friday February 22) with “Hard Ops 0097.6_Promethium_2” the “Bweight” option on selected edges does not work. I change the weight from 1 to 0 and it does not have any effect. In fact if i unsharp an edge with “Set SSharp” the mesh will still remain the same.
And this happens without applying any mirror to the mesh.

Please can you fix this, is an important option for me.
Thanks


(masterxeon1001) #1703

you might be working under an angle workflow. You can change that in the ctrl + ~ misc helper. Also the modifier can be changed to weight then the changes reflect.


(yolao) #1704

Works great, thanks @masterxeon1001, i cannot wait to check what new things you will add to Hard Ops next. Exciting times.


(Michael Knubben) #1705

Hey @masterxeon1001, any reason BoxCutter displays different things in the Top Bar and Properties Editor’s ‘Active Tool’ tab? My understanding is that those were meant to be the same thing in different locations.
Also, any chance you’d display the hotkeys in the status bar, where they are for Blender’s other tools?


(masterxeon1001) #1706

active tool tab is help now. N panel is alternate topbar

hotkey display is something we’ve discussed. We’re checking into it.


(oaschwab) #1707

I tried searching through this post but couldn’t find anything. Using current 2.8 here. Any reason why when I change the “activate boxcutter” keyboard shortcut and save the preferences it doesn’t remember it next time I start blender?


(masterxeon1001) #1708

there is a bug with active tools and hotkeys that we’re hoping to fix in the future but it is a known issue on our side.