Hard Ops Thread

commercial
add-ons
(masterxeon1001) #1872

now i see what youre talking about. Thanks!
it’ll be checked into.

1 Like

(Emrebel) #1873

Hello I am facing a weird issue, after using smart apply/ apply all modifiers all of my booleans vanish… the mesh just returns to its original shape. I am not sure if I am missing something or a bug?
Here is a small video to demonstrate the issue…
HardopsIssue.wmv (2.1 MB)

0 Likes

(masterxeon1001) #1874

you using the latest blender? Part of our recent issues involve not applying objects. So Im always on the lookout for that. However smart apply should work differently for non csharp meshes. For your situation I would use apply modifiers in the add mod menu.

However me may need to add support for applying vgroup but thats not as easy as it sounds. And stretches csharp a little farther than its initial scope.

The issue comes down to booleans nuking groups as the above video shows.

0 Likes

(masterxeon1001) #1875

Nowadays I work a little more free (outside of Csharpen) similar to the above video. Hope that gives more insight to what is going on there.

0 Likes

(Emrebel) #1876

I use the sorting feature to avoid the conflict between boolean and bevel…so the second case is less likely to happen… also using apply all modifiers produces same result

0 Likes

(Darknoodles) #1877

I did use only two objects. The subtility here is that the Slash technically works, but the “remaining” part is not showing up in the current scene, but is placed in the default one.
https://1drv.ms/u/s!Au_E_dJh9HFwm0mKsCnyl62sfZHJ
Edit: oops, gif got resized… Trying to get you a better one
Edit2: shoud be better now

0 Likes

(Benny G) #1878

Can you use maybe the new daily build beta for blender 2.8 …

0 Likes

(Darknoodles) #1879

In case that was aimed to me, i did try with the latest build too. (Not on the gif though, as the error is the same i opened the Blender install that was the closest to my mouse pointer :stuck_out_tongue: )

0 Likes

(Emrebel) #1880

@masterxeon1001 Seems like skipping the csharpen(as per your second video) solves the issue of booleans. I believe the issue is somehow tied to the way csharpen operates.

0 Likes

(colkai) #1881

CSharpen can control it’s actions, such as which modifiers it applies, maybe that is coming into effect? Have you tried altering those settings?

0 Likes

(masterxeon1001) #1882

5 Likes