Hard shadow edge.

I made a simple low-poly model and created a normal map to go with it. It’s far from perfect, but I’m mostly happy since it’s quite rushed.

What I am concerned about is the hard edges to the shadows that you can see below. The object is set to smooth and the normal map looks ok. I would have thought that these two things would cause the light to smooth out. Does anyone know how I can achieve this without increasing the polycount?


And here’s the normal map:


PS. Sorry the pics don’t show up. Couldn’t get it to work for some reason.


The pics opened for me. Have you checked normals? In edit mode, select all, then ctrl n…recalculate normals outside.

Best of Luck!

Thanks Obi.

I was unclear about the pics. I meant they didn’t display in this forum page, and that you need to follow a link to view them.

I recalculated normals outside just in case, but this wasn’t the problem. The shot I included has very dark shadows, which looks similar to incorrect normals, but in other frames where the shadows aren’t as dark, it is clear that it is just lighting this way due to large angles between faces.

Any other ideas?


Can you post a blend file?

Thanks Obi but I solved it. I had to turn off raytrace shadows on all lights in the scene. This seems odd as the problem only arose when the normal map was applied, rather than when I did anything to the lights, but it solved the problem.