Has Something Changed for HDR Probes as Environment Textures?

Okay, I can’t get any probe to work.
Steps I took.

Go to world,
Use nodes,
Surface: Background
Color ‘Environment Texture’
Open building_probe.hdr

Get nothing with Equirectangular or Mirror Ball,
Then I add Vector Mapping, Vector > Texture Coordinate | UV

Plus changed a bunch of other settings, still no HDR probe, just a smeared image in the background.


Ensure you are in Perspective view

That looks better, but still not clear and the render is still not right.