Has something changed in Blender 3.4 with the Add Curve: Sapling Tree Gen or is this a flaw?

I’m not going to jump to some conclusion since Blender frequently has changed and things get moved around or changed. I’ve added the Add Curve: Sapling Tree Gen through preferences as I have done in earlier versions yet this time when I use this feature option from the menu The Last Operator Panel appears yet everything is dead or not working, when you click on something nothing, again nothing is highlighted as it appeared in earlier versions of Blender. Is it possible things have been changed here and I need to go somewhere else, this feature may be in some sort of transition phase? On the other hand is this a flaw that needs some sort of correcting?

Works fine for me. Adjusting the various sections, using presets.
Using 3.4.1

I’m not quite sure what you mean by using presets. The Last Operator Panel has always worked with the default installation of Blender in the past without setting anything except checking the add on itself in preferences for Sapling Tree Generator.

Since my starting this forum thread, for the sake of comparison I tried the same version 3.4.1 in Windows 10 and Linux Fedora Workstation-Design Suite. The problem is most likely the Windows version of the program. Using the Linux tar download on Fedora the panel is operable in a normal fashion. For some reason the Windows .msi install has this problem. I tried to use a stand alone portable zip version in Windows yet the same thing there no panel functions. It is my conclusion that the Windows program has either some change done deliberately or a flaw that needs correction.

I believe they call this a “Last Operator Panel” since I have bought a book that is very good written by John M. Blain and he describes this panel (with the sapling tree generator it is the one used to make all the setting adjustments to the default tree that is created in your modeling screen for; pruning, leaves, geometry, branch splitting, branch growth, etc). Yet basically he describes it as the panel used to make adjustments in many tool options where once you leave that panel and click on something in your work area it will disappear and the setting adjustments are no longer available.

Hi. Down the very bottom of the Operator Panel is a Load Preset menu, with several presets for various trees.

Oh - I do use Linux, may be why it works for me.

If you go into preferences > Addons and expand the Sapling add-on (click the triangle) you will see a Report a Bug button.

Its possible this is a case where things using curves have problems (or are disabled for a month or two) as the curves are getting updated - to work better with Geometry Nodes. There has been a lot of that in the last year or so.

It does work fine in Windows with version 3.3.

I intended to send the bug report message after getting some input at this web site first. As I describe in my thread first writing, I did not want to jump to conclusions that it was an error.

Works also on Linux Debian Blender 3.4.1…

The standard settings for the Tend Flame shape seems to doesn’t change very much… but the changes
are more visible with for example the Conical shape…

That might be a standalone version and not the one found in the repositories as the default version used in the latest Debian operating system? I have Debian on an older machine, the version used there is 2.83.5 in the repository, Linux kernel 5.10, Bullseye 11.4. The Blender add on for Sapling Tree Generator works normally on this version.

Yes directly from blender.org … i’m on debian 9 (Stretch) … and yes i have to upgrade … Blender 3.5 doesn’t work… (up until 3.4.1 is fine) :wink:

Works fine on Win 3.4 for me.

Windows 10, portable Blender 3.4.0 works as expected. That panel is called Adjust Last Operation in the fine manual.