Havent been able to access blender.org for aaaages

For the last few months ive been unable to access www.blender.org

also devtalk.blender.org

I’ve tried different browsers. Terminal ping’d it. Tried deleting the cache and cookies even used on multiple computers (all on the same local network).

There is no sign that i cant access anything else on the web. Obviously i can access blenderartists.org fine. Its only www.blender.org.

Anyone have any ideas why? I’m guessing its to do with my network. Maybe something bans blender automatically… :confused: but thought maybe others have had a similar issue?

All of the official Blender web pages work for me.

Which country do you live in, that could affect what the problem could be?

Maybe try a VPN service to bypass any local filtering that might be going on?

Do you perhaps live under a totalitarian government in a country where the leadership has a passionate hate for small kitchen appliances?

Cheers Gavin, I did consider the hate towards food processors, but i think it unlikely, considering i live in New Zealand. I suppose the hate may exist on the private network setup where my office is part of.

Also i can access it on my phone if i use data its only the local network if i switch to wifi. Im almost certain there are no restrictions…i mean. BLenders come on!!!

I think a VPN would help. I literally just want to download latest 2.80 blender lol…IS THAT TOO MUCH TO ASK!!!


If you can not access the link above, paste it here:

Or in some other webproxy:


awesome yeah webproxy was what i needed. I didnt know they were free :slight_smile: cheers.

Yeah, the sites work fine for me, too, and I”m in New Zealand as well.

Though obviously I’m in a different part of the street from you. Whereabouts are you? I’m at number 17A.

I’m at 3671F on the street.

FYI: for those who dont know, NZ only has one street. Makes life simple.