having alot of trouble with blender 2.56 (the newest update)

please dont close this topic straight away i am in desperate need of help. i have been using blender2.53 for ages and i thought it was time to update so i downloaded blender 2.56 the one that was released on december 30th and now i dont have a desktop short cut to it. my blender documents wont open in blender when i click on them. i cant import .obj its really getting annoying. so i restarted my computer and installed it and still no desk top icon and i cant import .obj and i cant open the files when double clicking on them i have to open blender first then go on file and open the file and thats really inconveiniant. can someone please help me

just so you know im on windows vista

Download a newer build from www.graphicall.org

Two of your probs you can fix yourself in your OS - .blend file association and create your own desktop icon. The OBJ import I assume is now a blender “addon”.

(Gotta love the GUI generation: “i have to open blender first then go on file and open the file and thats really inconveiniant.” Waaa Waaa Waaa! I have to click like three extra times! Can u believe it? My poor index finger’s killing me! Waaaaaa…) Dude, do you really do that much file opening? You do spend some portion of your day actually working within a file, right?

ok ive made a shortcut that works when i click on it. but the files of my .blend when i click on them says choose program to open them with and it wont let me choose blender?

Right click on the .blend > Open With > Choose Default Program > Browse > Go to your blender2.56 directory, once you select blender.exe make sure that you select ‘always use this selected program to open files of these type’.

There has been some issues with .obj import I think in the newer versions, do a google search, look around to see whats going on with it. A google search would answer most of your problems posted in this thread I imagine.


I could be wrong, as I haven’t used a windows machine for quite a while, but ther should be an option to browse for the program you want to use. Then once you’ve selected blender there should be a check box saying something to the effect of “Always use this program for this filetype”.

http://social.answers.microsoft.com/Forums/en-US/w7files/thread/8a84fcec-22df-4942-8e35-d98dbe96e327 (The first answer.)
This worked for me. The issue was that it had previously been assigned to a different version of blender, which had been deleted, and that messed up the file association.

ok my blender has a shortcut on desktop that works. and it will open .obj

the only problem is the .blend files wont open in blender. i tried the “open with” and selected blender from the file but it dosnt appear on the selection of programs i can choose from to open it in. and i need it to open in blender coz when i send my .blends off to someone coz im working on a progect they cant open it coz its not selected to open in blender :S

likan1, did you happen to notice in AD-Edge’s instructions above the “Browse” step? It’s likely you’ll not see the “right” blender option listed in the possible applications. (You can have as many versions of blender installed as your hard drive will hold, BTW, but that’s another topic.) You’ll have to BROWSE (in other words, navigate to the right folder on your drive) to where the proper .EXE file is that you’d like associated with .blend files. And remember, just as he instructed, to select the “always use” checkbox so that Windows will remember this setting.

Let me see if I can wrap my head around the logic of this one… you need it properly associated on your PC so that when you send your .blend file off to your online buddy he can enjoy the convenience of simply double-clicking on said .blend file and have it open properly in Blender on his PC system? Wow… I’m simply at a loss for words as to the sheer… yikes :confused: :no: :rolleyes: (Sounds like a bit of an ID-ten-T error here…)

I’ve heard talk about how the “intranetz is jus’ one big ol’ compooter”, but don’t you think this is taking it a bit far? :smiley:

Oh, and BTW, you might get more distance from your help requests if you properly write out the word “because” rather than employing the constant use of the 4chan-esque “coz” shortcut. Just a thot… (Man, I shudder to think what the dictionary will look like in 20 years…:eek:)

this topic can be closed now i sorted it out mostly