Having .dll problems with runtime

I tried to save as a runtime game (2.49) I get an error that says “Could not copy file” However it does make a runtime game that works on my computer, so I tried the runtime that was saved on another Xp windows computer and i get vcomp90.dll is missing I downloaded Vcomp90.dll
and placed it where the .exe is I try to run again and this time i get python26.dll
is missing( this is happening on another computer, on my computer it works) I download and add python26 in the same folder and this time it runs, sort of. All i get is a background color and a few rock objects. Sounds, animations, etc Nothing works. The console says unable to get a material, in fact the list of materials it can’t get is long. Anyone have ideas on how to fix?
The runtime works fine on my computer.


Copy all the .dll’s in the blender directory and use them (paste them in the same folder as the runtime)

These are the.dll flies that i have. Still having problems check out the list Maybe you will see others i missed. Shouldn’t blender (2.49)do this when i save as a runtime?



You could also try it on other computers with BPPlayer, since it’s very similar to the runtime method.

I also have the following .dll in my blender 2.49B folder (wouldn’t it be easy to sort the files where blender is by type, and shift select all the libraries( .dll) afterwards?):

have you packed the images before making rutime?
File -->External Data -->pack into .blend

Could it be that simple Karakasimov? I tried what you suggested because i did not do that before and now on another computer most of it works now but a lot of my objects are black like a silhouette with no textures ? The console says “unable to initilze material image will not be availible” and it has a long list of those for each material it can’t get. Not sure if i am packing the textures correctly. I thought i was. I will try again this weekend when i can use another computer but at least no more .dll problems. Thanks