HDRI & Yafray problems

I’ve been making some proofs with HDRI textures with Blender-Yablex-Yafray 8) but there’s something I don’t understand yet. If you use the HDRI texture you can see it reflected on all reflective objects in the scene but I’ve read somewhere that HDRI textures ara used to illuminate the objects in the scene directly so you don’t have to put any light in it, but I’ve tried that and the result is a complete dark render. I’m wrong? What’s the trick with it?
Hope someone can put some light on this… :smiley:

Thanx :wink:

To use the HDRI image for lighting, do the following:

  1. Click on the HEMI LIGHT button in the GUI
  2. Set the power to 1.0
  3. Turn samples up to about 8-10 (higher values = less grain/longer render time)
  4. Assign the HDRI file in the GUI, complete with the path to the file
  5. Set up your scene as normal, (i.e. materials, etc)
  6. Export
  7. Open the xml file in a text editor
  8. Find the code for the HEMI LIGHT and delete the colour statement, (should look like <color= r,g,b>, or something similar).
  9. Render with YAFray.
    10 You should see a line come up on the console that says “No colour assigned to hemi light, using background colour instead”
  10. Wait for the render, then, wait some more for the render…
  11. Open the image file and see the glory of HDRI!!


You don’t need to do the XML stuff, just set all 3 color sliders on the HEMILIGHT to 0 and then it will use the HDRI.

:smiley: :smiley: Yuuuuujuuuuu :smiley: :smiley: !!
Yeah it works and it’s great. The illumination it’s much more realistic and it’s quite easy to set up, but… it’s possible not to see the hdri image as background image? because otherwise you have to put the camera in some place so you don’t focus background because always appears blurred :(.
Although it’s not the best image to appreciate the hdri features, here it comes my proof (it’s totally subrealistic, but i like it :P):


Thanks :wink:

I asked jandro about doing HDRI without the HDR as the background and he said that it is not possible right in the current version but he could add it pretty easily in an upcoming version.

I’m having a problem with keeping HDRI renders from being extremely grainy on all solid surfaces. I’ve tried turning up the hemilight samples and the raydepth, but it hasn’t helped. Any ideas?

All I do is turn up the samples. I leave the raydepth setting alone.

What are you setting it to? I usually go to 10 or more.


I had it at 10. I upped the minimum AA samples per pass and that fixed it (although the renders are now slow as crap).

LOL! Yeah. But if you want quality, you have to wait for it. I have rendered some stuff that has taken 4-5 hours.

For the Samples, I just set AA Samples to 4 and then MinAA Samples to 4. That is all.