Head modelling normals...

Hey Everyone,

Here is a picture of my first head in blender :slight_smile:

http://www.ultramedia.com.au/use/documents/1936/images/head.jpg

The problem I am having is with the normals in the mirrored linked duplicate. I don’t know how to ‘unreverse’ them. I looked in the online documentation and found the following bit of information:

In Blender 2.33 and earlier versions the OpenGL implementation causes mirrored linked duplicates to have wrong normals, so that one of the two halves is black. This is fixed in Blender 2.34, but older versions can use this technique anyway by setting the mesh to single sided while symmetrical modelling is used.

I’m using blender 2.35a so I guess the powers that be want to know that this is doing this again… I also tried what it suggests above and set my original half to single sided before duplicating it but it doesn’t fix the problem.

I also know about recalculate normals inside and recalculate normals outside and they don’t seem to help either…

Anyways, here is the blend file:
http://www.ultramedia.com.au/use/documents/1936/files/head.zip
Any ideas?

P.S. Thanks Tom and everyone for creating such a great app, I’ve just switched from max to blender (after five years) with the arrival of face and edge selection :slight_smile:

On the dark half select only one vert in edit mode and hit L with your mouse over it. That should select all the verts in that half and you can flip the normals to be facing the same as the other half. You can turn the normals on to see them in F9 and increase their length to make them visible.

%<

Hey Fligh,

Thanks for that, it helped me connect a few dots (har har - pardon the pun) about displaying ‘subobjects’ and normals.

The left side of the face was still dark as above after I fixed the normals, but when I moved the lamp to directly in front of the face, both sides were illuminated evenly.

I’d already joined the two meshes (ctrl-J) but I am still getting a visible edge down the center of the face… so I surfed around and found out about merging vertices (alt-M).

So I select two touching vertices on the forehead and merge them and choose ‘at center’ from the options and the following happens…

http://www.ultramedia.com.au/use/documents/1936/images/head_problem_02_a.jpg
http://www.ultramedia.com.au/use/documents/1936/images/head_problem_02_b.jpg

I can’t tell if it is a bug or if I’m doing something wrong… any ideas?

D’oh… figured it out…

Not sure why merging vertices does this, but if you just keep working your way around the edge, merging vertex pairs, they all equal each other out.

For instance in the picture above with the merged vertex that has pulled the contour lines down into a V shape, when I merged the next vertex ‘pair’ below it, it snapped back to its proper location. Looks like blenders doing exactly what it should be doing…

Rather than merging all those verts individually you could do a w-key and select remove doubles. You can set the max distance apart of the verts to join in the (F9)Editing->Mesh Tools panel->limit field.

GreyBeard

THAT is really good news - thanks Greybeard.

Because I’m coming from max, each time I find out about a feature in blender that does the equivalent of something in max, it lets bring a bunch of practice and experience straight into blender.

Makes me think, has anyone ever done a list of things in max that blender has an equivalent for? Sort of like a guide to migrating from max to blender…

btw, what do you all think of my head?