Heat wake using refraction?

You notice how in all movies w/ CG effects now, they have the heat wake after an aircraft or other vehicle passes. I’m talking about that distortion effect of the heat pouring out of the exhaust or engine.

I’ve been trying to duplicate that effect with no satisfying results using the new Raytrace/Refraction material options on metaballs. It doesn’t work on particles/halos–which would probably be ideal–and with the metaballs, it’s got a definite edge which doesn’t look right either. Has to be a soft edge and a subtle effect to add the realism.

I’m wondering if anyone has got any ideas on a technique for that effect in an animation.

Thanks in advance.

okay, you could use a stucci texture

I have done this before, back before raytracing even.

there is also a sequence plugin that does it, search for posts…

well, I will
https://blenderartists.org/forum/viewtopic.php?t=5496&highlight=blenderstuff

newer blends in same directory, the 3rd one uses a sphere around the camera, which allows things to line up better than the part cylinder

but still, I never perfected it and the plugin seems pretty good

Reading theese threads got me thinking. I put together this quick test and it doesn’t look too bad. Tell me what you think

http://www.freewebs.com/nitro3d/HeatDistortion2.avi

This is my first time posting a video so if it doesn’t work let me know. It’s about 1.7 MB in size.

Thanks

Jon

I think it would be easier to do this effect if blender can use ztransp with raytransp at the same time (or some sort of layering for the texture (can’t remember what it called))

Just a theory if it possible:
Use the cloud tex to bump a plane and refract it with ray transp. Use another cloud tex with colourband for the control of the alpha (make the other colour of the texture transparent (either black or white), map to alpha and use ztransp with it. Finaly use the sphere blend texture and again use the colourband to control the alpha (make the edge transparent and soft) and use ztrasp. Set alpha and dvar to 0 and set map to neg alpha. Animate the cloud texture so it will flick when it refracts and give nice alpha edge. Parent it with particle…and you know…

Look at this picture and imagine if the white bit refract :slight_smile:
http://sbup.jyscomputers.com/ada89/teo.jpg

Soooo why wait….???request it!!! :wink:

Edit: You dont need to use the colourband, it will behave the same.

Though I have thought about trying it I have never attempted it, but what I was thinking Id do would be to make a morph animation of some splotchy white patches morphing in to one another, and on a plane placed in front of the camera, mapping it to nor with the IOR cranked.

http://reblended.com/www/daveyboy/warp/warp_tute1.html

%<

Bravo!..if you read my last post(and understand it :stuck_out_tongue: ) ignore the raytrasp bit and make it as the image i show. Then mask it as the tute shows and bla…bla…blaa :smiley:

…If the plug-in work(never try it :stuck_out_tongue: )

It works!!

Here is my quick render.

http://sbup.jyscomputers.com/ada89/warp.avi

Only use one plane for the fx.

I couldn’t get 'ada89’s suggestion to work. If raytransp isn’t on, how can it refract? I tried both ways and couldn’t get it to refract properly.

I have 3 texture channels:
1st one: CloudBump - used a cloud tex w/ NOR
2nd: CloudMap - colorband w/ alpha 0 and Mapped to Alpha
3rd: Blend/Sphere - w/ & w/o colorband, Mapped to Alpha, DVar 0, NegAlpha

For material settings, have used both Ztransp and Raytransp, Alpha 0, Flat mapping w/ Orco. I see the cloud, but no refraction. When I use Raytransp, the whole plane refracts, not just the color area. What am I doing wrong?

Thanks for your help! :slight_smile:

(btw–couldn’t load your anim)

Just create the particle system as the image shows, then follow my tutorial, should be fairly easy to do.

Follow which tutorial? [email protected]–are you referring to the tutorial mentioned in ada89’s post?

Thanks.

Wait, i will create the .blend. I actualy use the warp plug-in. I use two scene. One is the mask of the cloud thing and one is the actual scene. Then you use the squencer, add two scence strip and the warp plug-in, render and wala.

You should check the link that fligh post
(I’m not so good at english…sorry :frowning: )

…and you need divx to watch it

Wow, this looks awesome, I’m going to go test it right now! :smiley:

http://sbup.jyscomputers.com/ada89/warpwave.blend

You need to download the plug-in too to make it work. Go to main scene and sequence mode(both can be chose at the top menu). If something wrong with the plug-in, just delete the strip and replace it with the one you download. Click shift at main then mask before you add the plug-in.

Was my example so bad? Did anyone actually look at my example avi?

You can’t direct link from freewebs, you should have created an html link. I doubt anyone has downloaded your video.

You can’t direct link from freewebs, you should have created an html link. I doubt anyone has downloaded your video.[/quote]
Not only that but I get a nice 1.5 KB/sec trying to download it.

Martin

I just notice somekinda bug in the plug-in. If the mask bit is at the edge of the screen, it will desort it and not ignore the edge…so you get unwanted effect. I hope blender can use ztransp and raytransp at the same time in the future.

Sorry about the download. I’ve never done this before. I’m still quite new to the Internet. I tried to make a quiktime movie to show everyone but it doesn’t work. Blender bug?

So how do I make an animation that everyone can see? Please help :frowning:

PS: Sorry teeth about the slow download. I compressed the file as much as I could. What kind of connection do you have?

ADSL 3 Mbps down, 800 Kbps up

Martin